1Password on Mastodon

1Password 8 not working with Duo enabled accounts

I downloaded the 1Password 8 early access version for macOS and signed in to my existing accounts, some super quick feedback before getting to the actual bug.

  • When first launching it offered my existing accounts to sign in to, I clicked one of them and then I could never get that UI back again, so I had to manually enter all the details for my other 3 accounts.
  • The "Sign in on 1Password.com" doesn't work well on macOS when you have multiple 1Password apps installed, I had to delete the old app before the links opened in the new app

Now for the actual issue:

I signed in to all my 1password accounts EXCEPT for my work account as it fails every time with:
"We weren't able to sign in to your account. Maybe there's a typo? Check your sign-in details and try again"

The only different between this account and the three that worked is Duo, the exact same credentials (copy pasted and tried multiple times) work on the legacy app and in the browser. I assume the Duo prompt just isn't firing in the new app so auth is failing.

1Password Version: 8.2.0-44.BETA
Extension Version: Not Provided
OS Version: 11.5.1


  • PeterG_1PPeterG_1P

    Team Member

    Hey @MarshallOfSound, thanks for letting us know you've encountered this issue. As I understand it, Duo support should be fully functioning in 1Password for Mac (Early Access), so our team members will confer on this so we can get to the bottom of what might be going on here. More to come!

    We appreciate your additional feedback on the new app, as well. I'll make a note of it for our developers.

  • elyscapeelyscape
    Community Member

    I'm seeing the same issue.

  • PeterG_1PPeterG_1P

    Team Member

    Thanks for letting us know, @elyscape, and my apologies that you've run into this issue. We'll investigate this and follow up here. Thank you for your patience!

  • jane.lewis_1Pjane.lewis_1P

    Team Member
    edited August 2021

    Thank you for reporting this, @MarshallOfSound and @elyscape. I'm currently working on a fix, but I can't seem to reproduce this problem on my local computer. If I understand correctly, you're attempting to add a new account by filling in the credentials manually and then hitting Sign In. What happens after that? Does the app get stuck on the loading screen, or does it immediately fail?

    Also, one other question - what is your default browser? Duo authentication attempts to open a browser window, so your issue might be specific to a certain browser not cooperating properly with 1Password.

    Once again, thank you for reporting this issue, and we'll try to get this resolved as fast as possible.

This discussion has been closed.