1Password on Mastodon

Please disable ⌘R keyboard shortcut (always loads "home page")

Currently v8 of your browser Electron App reloads the "home page" when (accidentally) typing ⌘R, taking me out of context when I navigated somewhere (for example somewhere in a nested tag).

Can you please disable the ⌘R keyboard shortcut?

This might be an Electron thing: when I accidentally do this in Slack when in a call, Slack will remove me from that call...

For now I will create a macro group in Keyboard Maestro to disable this keyboard shortcut in Electron Apps, but it would be nice if you fix this in 1Password itself.

1Password Version: 8.2.0-47
Extension Version: 2.0.6
OS Version: macOS 11.5.2


  • MitchMitch

    Team Member

    Thanks @XIII! Great catch, this is just here right now for beta development but we will remove it from production builds. (We're discussing having Command-R be a toggle shortcut to reveal passwords, what would you think about that?)


    Community Member

    The Alt/Option button is kind of muscle memory for me.

    However, this made me accidentally reveal one of my passwords, when pair programming with a colleague on my machine: I hit that key to open a menu option in a tool I though had focus (but 1Password still had the focus).

    For that reason I would prefer a more complex combo (Command-Option R?).

  • MitchMitch

    Team Member

    Great points. A lot of us also like Option to reveal but we haven’t put it back yet for exactly the reason you pointed out: people kept pressing Option accidentally or as part of another shortcut and revealed all their passwords. (It’s especially bad in the age of all-day Zoom calls… I’ve done it. 😳)

    We are looking into a safer solution that may involve a preference or at least a more deliberate key sequence. Thanks for sharing your thoughts on this!

This discussion has been closed.