Clear the cli config or cleanly uninstall the cli -- bc I need to forget an old username

Using a mac os 11.5, bash terminal, installed cli w homebrew.

I have a 1pass account that is managed by my employer. They recently updated my email. That updated my 1pass username (to the new email address). The 1pass desktop and webapp gui based software still works fine for me. New username, same pw, nothing changed. The cli, however, still is trying to use the old un and it's failing to create new sessions or "signin". I can't find where the config is stored. I tried merely removing everything with a brew "uninstall" then "install again" but it still remembers the same un. There is no "~/.op" folder on my machine.


1Password Version: app 7.8.6 -- cli 1.11.2
Extension Version: n/a
OS Version: mac os 11.5

Comments

  • ag_yaronag_yaron

    Team Member
    edited August 17

    Hey @dangerdene ,

    Have you tried to use the forget command? if not, please try this:
    op forget <account name/email/shorthand>

    So if you used to signin with a shorthand ( op signin Company1 ) , simply use the forget command instead of the signin command ( op forget Company1) .

  • edited August 17

    Thanks @ag_yaron ! That did the trick. I'm up and running again. Appreciate the quick response.

  • ag_yaronag_yaron

    Team Member

    I'm glad to hear it!
    You are most welcome :chuffed::+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file