1Password Linux doesn't auto lock with user account nor after the idle delay

Hi,

With the "auto lock" setting enabled,
When I lock my user account without putting the computer to sleep,
Then the desktop app doesn't lock.

I assume this is unintentionnal since the settings is "Lock 1Password when the computer gets locked" (my guess for the English version)
It still auto-locks properly when the computer goes to sleep.

Also, with a given delay of not using the system set in the settings (e.g. 1 min),
When I shut down my mouse and don't touch the keyboard for a bit more than the delay,
The app doesn't auto-lock.

Have you already encountered these issues?

Best regards,
Rémy


1Password Version: 8.1.1 (80101004)
Extension Version: 2.0.5 on Brave Browser
OS Version: Linux Mint 20, Cinnamon 4.6.7, Kernel 5.4.0-81-gen

Comments

  • PeterG_1PPeterG_1P

    Team Member
    edited August 25

    Hello Rémy (@remym19), thanks for this!

    With the "auto lock" setting enabled,When I lock my user account without putting the computer to sleep, Then the desktop app doesn't lock.

    That doesn't sound like what I'd expect. Our team will be happy to follow up on this issue for you.

    Also, with a given delay of not using the system set in the settings (e.g. 1 min), When I shut down my mouse and don't touch the keyboard for a bit more than the delay, The app doesn't auto-lock.

    My understanding is that there can sometimes be system-specific reasons for this. This setting is based on your system idle time, but sometimes there can be factors other than simply moving your mouse or touching your keyboard that can affect this. It'd be hard to determine without knowing more about specific your setup, but again we'll be happy to pursue this and see what we can figure out!

    If you can send us a short email at [email protected] with a link to this conversation, we can start figuring out what might be behind this unexpected lock behavior. Thank you again for letting us know!

  • SavanniSavanni

    Team Member

    Hi, @remym19.

    The 1-minute time-out can vary by a few seconds because of the frequency at which we check the idle time, but it should absolutely not be more than 10 seconds late. Please let me know if it is.

    I'll have to do some research, but it would seem that on the Lock matter, Mint + Cinnamon is not necessarily sending Lock notifications in the same way as the systems that I have. I don't know that combination very well as I'm most familiar with Sway and with Gnome Shell. So I'll have some things I need to learn.

    Various Linux configurations actually emit these signals in very different ways, and so this is kind of a matter of researching the different APIs.

  • Hi, thank you for your answers, sorry I didn't get back early.

    I just send an email to the support address as requested.

    Ok for the delay.
    I did the test again in the following conditions: app version 8.2.0 (production 80200063), 1 min auto-lock delay in the settings, mouse and keyboard off, app opened on 1 screen and Brave opened on another screen with the browser extension installed.
    After 2 min flat, the app remained unlocked.
    I also remember coming back to my desk after more than 15 min and finding the app unlocked a while ago.

    Ok for the possible link to the Linux configuration.
    I had also though of something like that given the variety of Linux distributions.

    Best regards

  • ag_mike_dag_mike_d

    Team Member

    Hi @remym19! Thanks for getting back to us. We've received your response and we'll get back to you as soon as we can. Thanks!

    ref: YIP-79356-149

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file