1Password Snap update schedule

edited August 31 in Linux

Hi,

I'm running 1Password as an APT and Snap installs on separate computers. Last week I received an update to a new 8.2.0 version on the APT version. The snap package has not yet been updated even the update has been out for a week https://releases.1password.com/linux/8.2/. Are Snaps usually updated much later or is there another issue here? In release notes there is a link to snapcraft.io that also says the most recent version still being 8.1.1 https://snapcraft.io/1password.

Thanks for the Linux version <3


1Password Version: 1Password for Linux 8.1.1
Extension Version: Not Provided
OS Version: Ubuntu 20.04

Comments

  • Hi @LatteCoffee,

    I think we missed you by a few hours. Please check https://snapcraft.io/1password again, you should see version 8.2.0 available in in the stable channel and 8.2.2 available in the beta channel.

    Normally we will release the Snaps shortly after the apt release. Our publishing integration with snapcraft.io broke, and was restored yesterday.

    Thanks,

    James - Senior Build Engineer

  • Hi,

    thanks for the response. Good to hear that it was just an anomaly with the snap. I will update it tomorrow!

  • edited September 3

    Hi,

    I run into a problem with the new snap. 1Password crashes on start. I can see the toolbar icon in the top corner and and empty window. When starting from terminal I can see the following fatal error:

    FATAL:platform_shared_memory_region_posix.cc(255)] This is frequently caused by incorrect permissions on /dev/shm. Try 'sudo chmod 1777 /dev/shm' to fix.

    I tried reinstalling the snap with snap remove --purge 1password && snap install 1password but the error still occurs. I also checked snap permission and they seem to be same as before with everything else allowed except " Read/Write files on removable storage devices"

    I haven't tried the beta. Any ideas what might be the issue?

    Tested on Ubuntu 20.04 LTS. Haven't tested yet on 21.04. Also no previous revision before the current 59 revision are available anymore so I cannot revert back to revision 58.

  • edited September 4

    I now tested this with Ubuntu 21.10 and the same thing is happening there. Beta channel does not solve the issue.

  • PeterG_1PPeterG_1P

    Team Member

    Hi @LatteCoffee, our apologies for the issue here. Our Linux team is going to see about getting to the bottom of this. Thanks for letting us know that this issue arose for you - and we'll be back with updates as soon as possible. We appreciate your patience!

  • Hi,

    any news yet? Do you need more information about the issue?

  • PeterG_1PPeterG_1P

    Team Member

    Hi @LatteCoffee, thanks for checking in. We've managed to reproduce the issue on our end and get the related diagnostic information as well - always a good start! While I can't say exactly when a fix will be available, we are working on it, and will iterate through this as quickly as possible to get the problem resolved for you (and other folks who have encountered this problem). Thanks for bearing with us while we get it worked out!

  • @LatteCoffee Please try again. We believe the issue has been fixed in 8.2.1 on the stable channel and 8.32.2-28.BETA on the beta channel.

    With the exception of this bug, these releases are identical to 8.2.0 and 8.2.2-28.BETA linux releases on the other package management systems.

    Thank you for your patience.

    James - Senior Build Engineer

  • Hi,

    tested the new version now on Ubuntu 21.04 and the issue is resolved. Thank you for the help and fix!

  • BlakeBlake

    Team Member

    We're glad to hear that did the trick! Thanks for sticking with us while we got things worked out! 💙

  • Is a deb of 8.2.1 going to be released? only seeing 8.2.0 in repo and also having blank screen problem

    apt-cache madison 1password
     1password |      8.2.0 | https://downloads.1password.com/linux/debian/amd64 stable/main amd64 Packages
    
  • 1P_Claudio1P_Claudio

    Team Member

    Hey @vaelen! Version 8.2.0 is the latest release of 1Password. The Snap store has a different release number (8.2.1) as we had to push an update to fix a bug, but it's the same 1Password version.

    On that note, I am sorry to hear that you're also having a blank screen issue. We'll be happy to help! Could you write in to [email protected] and link back to this thread? We'll pick it up right away and look into what's going on. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file