1Pass classic not working in Firefox- icon blinks

After several re-installs, restarts, etc, I can't get the classic extension to work with Firefox. I'm unable to click on it and the actual icon just flashes. I'm using Firefox 92.0 on a Macbook Pro running macOS 11.5.2.

The standalone extension works fine, but doesn't have access to touch ID like the classic one.

One other note, the plugin works fine with Safari, but not Edge.

Is there a preference file kicking around somewhere or something else I have to delete? As mentioned above, restarting has no effect.

Thanks in advance


1Password Version: 7.8.7
Extension Version: 4.7.5.90
OS Version: mac os 11.5.2

Comments

  • ag_yaronag_yaron

    Team Member

    Hey @seaneee ,

    Indeed, sounds like something went wrong with your 1Password 7 desktop app, as it should connect to both extensions (old and new, allowing Touch ID unlock with both), but it seems to be unable to do so.

    Please try the following:

    1. Right click the little 1Password icon in your Mac's menu bar (where the clock is) and select "Quit 1Password Completely".
    2. Go to your Applications folder and delete the 1Password app. Do not use any 3rd party cleaning apps! Perform this task manually and your data will not be deleted.
    3. Restart your Mac.
    4. Download and install a fresh copy of 1Password: https://1password.com/downloads/
    5. Open 1Password, then open your browser and see if things work properly.

    If everything works, I'd recommend you try the new extension one more time, as it is no longer standalone and you will be able to enjoy all the new features alongside Touch ID unlock :)

    In case the issue persists, we will need to get a diagnostics report from your computer to investigate further. Please send it to [email protected]: https://support.1password.com/diagnostics/

  • thanks for the quick response.

    Unfortunately, the steps above didn't work. Both Firefox and Edge have the option to integrate checked, but still no touch ID. The other weird thing is the app itself doesn't recognize the plug-in for either browser — I get the "get the extension" notification.

    Side note, I have a second MBP, same OS, Same 1password. It works perfectly.

  • ag_anaag_ana

    Team Member

    @seaneee:

    Both Firefox and Edge have the option to integrate checked, but still no touch ID.

    Can you confirm the version of the browser extension that you have installed in these browsers? You wrote that you are using extension version 4.7.5.90, but the setting you are referring to is not found in this old classic extension, so it would be useful if you could clarify :+1:

  • ag_yaronag_yaron

    Team Member
    edited September 13

    Also, please do send us the diagnostics report I've asked in the previous message, it sounds like somethings wrong with the desktop app and we'll need to investigate further :)

  • Sorry for the confusion. The extension is v. 2.0.5 and the app is Version 7.8.7 (70807004), Edge is using 2.0.5.

    I also emailed the diagnostics report to the address above. Thanks!

  • Thanks @seaneee! I see we received your email. Let's continue troubleshooting there. :smile:

    ref: JXM-69524-947

  • ag_anaag_ana

    Team Member

    On behalf of Chantelle, you are welcome :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file