Mac beta build keep stealing focus

I've just installed latest 8 beta today and found it very annoying. Basically I can't minimize the window as it keeps popping back and steal my window focus.

I've tried reverting back to version 7 and this no longer appears. Installing again and it appears again.

Has anyone else found this ?


1Password Version: 8.2.2-39.BETA
Extension Version: Not Provided
OS Version: macOS 11.5.2

Comments

  • PeterG_1PPeterG_1P

    Team Member

    Hi @poomz, thanks for informing us about this, and I'm sorry your experience with the Beta hasn't been a more satisfactory one so far.

    In the interest of troubleshooting this issue: have you noticed if there is any particular workflow, or series of steps, that causes this problem to occur? Or does 1Password just keep un-minimizing itself and popping up to steal focus no matter what you do?

    Any specifics might help us track this down and fix it (and would be highly appreciated besides). Thanks again for alerting us to the issue!

  • Thanks for response. Actually no correlation I could observed. I have bartender, which seems to release fix mentioning 1password 8 but had tried exiting bartender and nothing was changed.

    Tried ignoring it and moved the window to far away at the edge of my monitor (I’m using 49 inches external display in clamshell mode so it really was out of my focus area) but the keyboard focus stealing every 5-10 seconds made doing any real work impossible.

    Also the window, when I moved it almost off screen would spring back to show its full window near that edge of the monitor after a while.

    I also tried exiting the program by clicking the status menu icon and choose exit which works until next 5-10 seconds cycle and somehow something bring it back to life.

    Only when I exit, and move the app to trash folder it can finally stop.

  • roustemroustem AgileBits Founder

    Team Member
    edited September 15

    I am sorry about the trouble, @poomz! If this happens again, would you be able to run this command in Terminal and see if it outputs anything?

    xattr /Applications/1Password.app
    

    Also, do you remember if 1Password.app was in your /Applications folder or somewhere else?

  • Ok I can try again tomorrow see if anything will change. It’s easy enough to rollback to 7.

    For the second question, I thought I had moved to application before starting but not 100% sure. It might be that I launched the program directly from download folder.

  • How are things for you at this point, @poomz?

  • I just tried again and for some reasons, it works normally now. Maybe 1Password 8 got updated, maybe because I also install latest Big Sur patch or maybe the stars just align ;)

    I'm a happy user now.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file