Almost every input field is covered with 1password suggestions

Hi,
Since I 'm trying out 1password 8 I'm seeing the inline suggestions for almost every input field in forms.
In the screenshot I'm changing digits and cannot see the digits, because 1password blocks the editting.


How can I change that?

Thanks!
~ Charlie


1Password Version: 8.2.2-39.BETA
Extension Version: 2.0.5
OS Version: MacOS 11.5.2

Comments

  • ag_anaag_ana

    Team Member

    Hi @primeminister!

    Please click on Suggestions and select Hide on this page.

    Can you however share the URL to this form? Our developers can look at the website and see if there is something they can do so 1Password suggestions won't show up automatically.

  • Hey @primeminister !

    You could just hit ESC and the suggestions window should disappear for that session.

  • Hi @ag_ana, thanks for your answer. I cannot share this URL, because it is behind SSO. I will update this thread when I find it somewhere else.

    When I hide it on this page, will also other fields which are relevant will be excluded from 1password inline suggestions?

  • DenalBDenalB
    edited September 15

    When I hide it on this page, will also other fields which are relevant will be excluded from 1password inline suggestions?

    Yes! If you hit ESC or hide it on this page, you have to click on that 1Password icon at the end of a field for getting the suggestions again.

    But if you close the browser and open the site again, the suggestions window is popping up again. It's just a temporary action.

  • Hi @DenalB ,
    Thanks!
    In this case it will not work, because it is a "click to edit" field with javascript. Also it will not hide the 1password logo inside the input field. It will only hide the dropdown with suggestions. And the 1p logo inside the input field is covering my original value

  • And the 1p logo inside the input field is covering my original value

    Ah, okay. I didn't see the value behind the icon. :(

  • @ag_ana Can you convert this to a bug report?
    1. Logo in input field is covering the original value
    2. Cannot exclude input field permanently from inline 1password suggestions (feature, but still annoying)

  • ag_anaag_ana

    Team Member

    @primeminister:

    If you want, we can try looking at the page details directly:

    1. Get to the page where 1Password shows up in places you don't want it to.
    2. Right-click the 1Password extension icon on the top right corner of your browser and select "Help" -> "Collect Page Structure".
    3. A file will be downloaded in your browser. That is the file you can email us along side a description and a screenshot of the webpage showing the issue with 1Password.

    You can use [email protected] to send the message. After you have sent the email, please post the ticket number you received so we can locate your message and connect it with this forum discussion.

    Looking forward to your message!

  • Hi @ag_ana ,
    I send the message to support and the ticket number is: [#FZL-79269-654]

    Thanks!

  • ag_anaag_ana

    Team Member

    @primeminister:

    Thank you! I confirm that I have managed to locate your message in our system :+1: We will take a look and someone will get back to your email as soon as possible.

    Thank you for your patience!

    ref: FZL-79269-654

  • Hi, Just for other people who have the same issue an update from 1p support team:

    I can understand if you find this feature a bit intrusive. You can dismiss 1Password easily by pressing the ESC key on your keyboard, or you can turn that behaviour off completely if you'd like, here's how:

    1. Right click the 1Password icon in the toolbar of your browser
    2. Click Settings
    3. Toggle off 'Show autofill menu on field focus'.

    This will prevent the inline menu from appearing automatically. You will then be able to call the inline menu on command by simply clicking the little 1Password icon that shows up on the right corner of the field you'd like to autofill/save.

  • But this doesn't solve your problem, right? The 1Password icon still is located in the right corner of the fields and is hiding values entered there...

  • ag_anaag_ana

    Team Member

    Thank you for sharing @primeminister :)

  • Correct @DenalB , It does not solve my problem. I answered the support with the same answer.
    Was just to help other people reading the forum and this thread.

  • ag_anaag_ana

    Team Member

    Our developers can now take a look at the website directly and see if there is anything they can do, but in the meantime the workaround should help :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file