Autofill popup instant disappears on IOS 15, iPhone/iPad on Chrome, Firefox & Safari...

CrashDDLCrashDDL
edited September 27 in iOS

Hi,

I have iOS 15 on my iPhone 11 Pro Max & iPad Pro 12.9 (Gen 5).
I have 1Password 7.7.8 installed on both devices.
I have Settings>Passwords enabled and set to 1Password only option.
I have Autofill enabled in the 1Password app as well.
The 1Password app works for the most part, I can do everything I would expect, even syncing with Dropbox works.
The problems start when trying to use Autofill in a browser.

Symptoms:

  • Option to use Passwords doesn't even show on the username page of eBay or any other login page.
  • After manually typing in the email or username and pressing next I finally get the Key icon with Passwords next to it on the onscreen keyboard. This is where the problem starts:
    At the first time, when I click on it after a restart of device, the 1Password app is visible and slides up from the bottom of the screen but before we would get to the face ID part, it disappears. Any consequent time the animation doesn't even show anymore, you can see it starts and almost instantly vanishes. I tested and have the same result on Chrome, Firefox and Safari, using both devices and seeing the exact same behavior.

Is this something known? Any suggestions on how to solve this would be great...


1Password Version: 7.7.8
Extension Version: Not Provided
OS Version: iOS 15

Comments

  • Correction, my 1Password version is 7.8.1m the latest.
    I tested the same version on another iPad in the house and it runs fine on iOS 14.7...

  • So I believe I identified the culprit:
    The error only happens when 3 vaults (not sure if even more makes a difference) are used on the 1Password app on the iOS device.
    I was able to replicate the error every time I added the 3rd Vault.
    I always have Vault 1 as Default and add Vault 2 & 3 to it.
    Vault 1 & 2 works fine. Vault 1 & 3 works fine.
    Adding the 3rd vault in any order brings out the error of disappearing Autofill popup window.
    Both Vault 2 & 3 has many attachments although I doubt that matters here.

  • After spending way too much time on this, I finally know exactly the cause of this:
    It there are 450 or more attachments in the vaults, be that single or multiple vaults, then the Autofill popup on iOS will fail.
    This can be reproduced successfully. It will work at 449 and fail on anything above.

  • Hi @CrashDDL:

    Thanks for letting us know about this. I'm working on reproducing this now. To confirm, is this a standalone vault with 450 items having attachments, or a 1Password.com vault with 450 documents?

    Thanks!

  • I just created a standalone vault to test with, and had 450 login items each with an attachment. I wasn't able to replicate the issue around AutoFill. With that in mind, I'd like to ask you to create a diagnostics report from your iOS device so I can get some more visibility as to what may be going on:

    Sending Diagnostics Reports (iOS)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    You should receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks very much!

  • CrashDDLCrashDDL
    edited September 27

    It is a vault with lots of Secure Notes, each have 3-5 attached pictures. Also some login and app info has attachments.

    I will send Diagnostics from both devices in the next hour.

  • CrashDDLCrashDDL
    edited September 27

    I just sent Diagnostics from both devices. I got no feedback of any kind so I can only hope it was successful. Please let me know if you don't have it. Thanks.

    I should mention that the 450 might not the exact. I get consistent error with 453 though.

  • Hi @CrashDDL, thanks for getting back to me. Just to confirm, do you have an account configured in the Apple Mail app? Sending diagnostics reports uses the Apple Mail app, and I'm not seeing any emails from you containing any diagnostic information in our system.

    Thanks!

  • Apparently I did on the iPad but not on the iPhone. I just sent the emails out from the iPhone just now. I also have a confirmation email on the iPad about sending in the report.

  • Great, thank you. If you could post the Support ID codes (it'll look like [#ABC-12345-678]) you received so I can look these reports up in our system, I can take a further look at what might be going on with this.

    Cheers!

  • [#ISZ-79673-628] for the iPad.
    The iPhone is still not sending the report. I am working on it. :)

  • I had to factory reset the iPhone to get mail working again. I reinstalled 1Password and got the same issue as before. I just sent the iOS report in and put the support ID & the word iPhone in the title. I hope that will help.

  • Hi @CrashDDL, I've located your diagnostics now. We're taking a closer look at them and we'll be in touch via email.

    Cheers!

  • I’m having a similar issue with 7.8.2 on iOS 15. The Safari extension works, but trying to auto fill in any other app will cause the keyboard to disappear and will freeze the app for 10-15 seconds before I can switch back to the keyboard. I’m able to replicate With over 500 items in All Vaults and with under 50. I don’t have attachments on many of my entries.

  • I am haring the same issues on iOS 15 on my mac and iPhone everything Works fine ipad 12 pro it does not if i try to installatie the extensions i first get a strange Firefox page that says to install Firefox? I Both have standaard Firefox and Firefox focus Both have the same issue. Why does Firefox ask me to install Firefox when all other iOS and non iOS (IPHONE13 pro max is same iOS as iPad Pro) do not? And of course why does it not show me the option of ios passwords and 1Password? How can i install it to only have 1Password as my main password manager.

  • I am having the same issue. iOS 15 / 1Password 7.9.3 / Firefox 39.0. I have very few attachments and around ~1500 entries in a single unshared Vault.

    I don’t know if this is a Firefox issue, iOS issue, or 1Password issue. Needless to say, it is really inconvenient.

  • Hey @Kordaat / @matthewhsu:

    Thanks for adding your input to this. We're still investigating and hope to know more soon. To get a little more insight as to what might be happening, I'd like to ask you to create a diagnostics report from your iOS device:

    Sending Diagnostics Reports (iOS)

    Attach the diagnostics to an email message addressed to [email protected].

    With your email please include:

    You should both receive an automated reply from our BitBot assistant with a Support ID number. Please post that number here. Thanks very much!

    ref: apple-5509

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file