openSUSE + RPM Blank Screen

SystemSystem

Team Member
This discussion was created from comments split from: FYI for openSUSE users.

Comments

  • Hi. In the mean time I have run into a more serious problem. Ever since the latest updates to openSUSE Tumbleweed none of the (RPM) versions of 1password allow me to login, as they simply show a blank screen when selecting "open 1password". The app seems to be running fine, but simply does not display anything. Anything I can do to provide you with logfiles?

  • PeterG_1PPeterG_1P

    Team Member
    edited September 28

    Hi @Frits, sorry to hear of this - we definitely would like to investigate, and logs would be very welcome!

    There is a 1Password logs directory located at ~/.config/1Password/logs. If you can zip that up and attach it to an email to [email protected], our team will go through the data to figure out what might be going on here.

    And we'll look forward to helping you get 1Password fully up and running! 🤝

    ref: FDA-76196-237

  • Hi. No need to be sorry. As far as I can see there is nothing weird in the log. No error messages or anything.
    It might have to do with a recent update to libc, which seems to have broken some programs. (electron based or not). The program I use for automatic backups to the cloud (Insync (https://www.insynchq.com/)) has exactly the same problem with multiple people mentioning the bug. Somewhere in forums people mentioned a couple more that show this behavior since the libc version bump.

    I'll send the logfile and include a screenshot as well.

  • Having the same issue, dnf is giving a broken dependency error saying nothing provides systemd-udev, not sure if that's the cause or an additional issue along with libc.

  • 1P_Claudio1P_Claudio

    Team Member
    edited September 28

    Hi @rcj32 Starting to look like this is something we need to snag as soon as possible - would you mind reaching out to us at [email protected] and provide your logs? There is a 1Password logs directory located at ~/.config/1Password/logs

    We're investigating this issue at the moment, so if we're able to confirm that the cause of the dependency error is the same we'll be able to personally follow up with you on this via email.

    Please reference this post when you write in, and we'll pick things up there! :)

    ref: MUT-85624-394

  • Great, I've just sent in an email with my logs. Thanks.

  • 1P_Claudio1P_Claudio

    Team Member
    edited September 28

    Hey folks,

    We've been looking into this on our end and have 1Password running normally with the below:

    1. Download the latest RPM beta of 1Password here.
    2. During the install process, YaST will throw up a warning about systemd-udev, Select option 2, ignoring any dependencies.

    image

    1. Once the install is complete, open Terminal and run 1Password with the --disable-gpu flag.

    This should allow 1Password to start normally now.

    @Frits @rcj32 Tagging you both for awareness, but we will have reached out to you both via email too. :)

  • Thanks. Received the email and instructions. Will try it out as early as possible today. I really appreciate the responsiveness of you (plural) in trying to solve this problem.

  • Success! I can confirm that it works.

  • PeterG_1PPeterG_1P

    Team Member

    Great to hear, @Frits. Thanks for the update! 😁

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file