run 1password as root

Hi I have a problem run 1password as root for linux (fedora34, KDE plasma 5.22.5, X11), ..."Running as root without --no-sandbox is not supported.", please your help!
pd. I try with /opt/1Password/1password --no-sandbox command but not work


1Password Version: 1password-8.2.0-1.x86_64
Extension Version: Not Provided
OS Version: Fedora 34

Comments

  • PeterG_1PPeterG_1P

    Team Member
    edited October 2

    Hi @ralmeida, thanks for this question!

    If possible, it'll be a good to avoid running 1Password as root. Our security model is built with users running regular user permissions (not superuser ones), and the 1Password app itself doing the same thing. While it's possible that might change at some point, that would require additional hardening and to my knowledge that use case isn't something we're currently focusing on.

    Is there a reason, for example some part of your workflow, that requires you to run as root in this situation? Feel free to let us know here - and if your response includes any security considerations you'd rather not post in a forum, feel free to follow up with us at [email protected] and we'll follow up there. 🙂

  • Hi @PeterG_1P
    Well, in a previous version I was able to execute 1password as root, the only user that I have created is root and it is the only one with which I have been working since 2004.
    I understand your security considerations but I really do work with all my applications as root and this would be the only one I could not work with. I am a subscriber of the application and I await your help
    pd. I have worked with several password managers such as keepersecurity, bitwarden and dashlane in fedora as root without any problem !!
    thanks for the response

  • BlakeBlake

    Team Member

    @ralmeida

    While I understand you may have used different password managers in the past that behave differently, 1Password for Linux is not inherently designed to run as root.

    If you try running 1Password normally (without root permissions) does the app start and run normally?

  • @blake when i run as normal user, same problem... ..."Running as root without --no-sandbox is not supported."

  • BlakeBlake

    Team Member

    Hmm. That's a bit strange. Could you share what installation method you chose 1Password for Linux on Fedora?

  • I have a 1pass repo: 1password.repo after
    dnf install 1password
    .. thnx

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file