autofill fails for bobsredmill.com

Autofill completely fails when checking out at bobsredmill.com.

MacOS 11.6
Safari 15.0
1Password 7
Version 7.8.8 (70808005) purchased from 1Password Store

It tried to auto-fill and I got the Safari pop-up asking if I wanted to fill data from 1Password, but it failed. The Safari pop-up then triggered for every field. Very annoying


1Password Version: 1Password 7 Version 7.8.8 (70808005)
Extension Version: 7.8.8
OS Version: MacOS 11.6

Comments

  • ag_yaronag_yaron

    Team Member

    Hey @margaretamartin ,

    Did you attempt to autofill the login form (username and password) on this website to sign into your account, or did you try to autofill your identity (address, name, phone number etc...) for shipping info?

    When I try to checkout on this website, 1Password suggest I autofill my login item (username and password), but if I click the 1Password icon in Safari's toolbar and select my identity item and autofill it, it will autofill all fields on that form correctly, including my email, first and last name, address etc.

    Is that not what you are experiencing?

  • I don't have an account on that site. I was trying to autofill my identity. I selected one from the drop-down list that appears in the field, but it did nothing. I also tried selecting it from the 1Password app. That also failed to fill in. But I kept getting the 1Password prompt to let it fill in info, so clearly something was triggered.

    I did not use the icon in Safari's toolbar. I never do, because I touch-type.

  • ag_yaronag_yaron

    Team Member

    Thanks for the info @margaretamartin ,
    Can you please try filling your identity item from the extension's icon in Safari's toolbar and see if that works as expected or if you are still experiencing the issue?

    You can also test identity autofilling on our test website if you'd like: https://fill.dev/form/identity-simple

    In case it doesn't work, I suggest you try creating a brand new identity item in your 1Password, fill it out with all of your information, then try to use the new identity and see if it works better.

  • I just put a test order together and now the auto-fill worked just fine. I don't know who's at fault here, but because I got repeated 1Password prompts, it seems clear that 1Password was at least attempting to do the fill. I wish I knew how to fix this other than restarting the computer (not a viable option when you're in the middle of an order).

  • ag_chantelleag_chantelle

    Team Member

    @margaretamartin

    You're right, it's not ideal to have to restart when you're mid workflow. It's possible a pending update needed a chance to complete, which was facilitated by the restart. If you do encounter it again, let us know and we'll be happy to investigate further for you.

  • @ag_chantelle Thanks! I will definitely report this if I see it again.

  • ag_anaag_ana

    Team Member

    Sounds good, thank you @margaretamartin :+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file