1P inserts wrong email address

I'm using the latest Chrome extension, and I attached a screenshot that displays the problem. When I log into nytimes.com, 1P fills in my email address as [email protected] The problem is that the email address is [email protected] A second screenshot shows what's in my 1P settings. I do, however, use the yahoo email account for most of my other logins, and I used it at the nyt.com domain a long time ago. Is there anything I can do to make 1P enter my gmail address? Thanks.


1Password Version: Not Provided
Extension Version: 2.1.3
OS Version: Win 10x64

Comments

  • ag_anaag_ana

    Team Member

    Hi @jimmyweg!

    The wrong suggestion is coming from Chrome, not from 1Password. You can either remove the wrong email from the suggested list of emails that Chrome provides, or you can remove Chrome suggestions altogether:

    Turn off the built-in password manager in your browser

  • Thanks very much, but I have no email addresses or passwords stored in Chrome (as far as I can tell), and all autofill options are turned off. Am I missing something?

  • jack.plattenjack.platten

    Team Member

    Hi @jimmyweg:

    Do you have an Identity item with your @yahoo.com email address? The New York Times website is both a registration page and login page, so 1Password suggests possible emails from Identity items to register. We're already tracking this so I've added your voice to consider suggesting Login items on this page as well.

    Jack

    ref: dev/core/core#10413

  • Thanks. Yes, I have many user IDs set to Yahoo. NYT is my only Gmail ID and the only site that presents a problem. And for some reason, I get logged on automatically to NYT when 1P is closed, cookies are cleared, and there is nothing saved in Chrome. I also set NYT to not "remember" me.

  • If it’s both a login and a registration page, and you have logins, obviously it should show your logins too! I’d go so far as to say it should show your logins first and then any email suggestions later. I have no idea why this was changed.

    I use 1P both for personal and for work, so I have many items belonging to either email address (and some with other emails). I have an identity field in my personal vault, but not one in my work vault. Do I now have to make an identity field for my work address so 1Password will show logins for that one properly on pages like these?

    This is the first time in a while I’ve really, really wanted to roll back a 1Password update. 😔 The new filling suggestions check is just way too aggressive and if people have to disable the dropdown to overcome it, it’s defeating the purpose. Unfortunately, the extensions auto-update, so rolling back is just not really possible.

  • ag_yaronag_yaron

    Team Member
    edited October 13

    Hey @andmade ,

    This is a regression that will be fixed in a future update :)
    For now, you can still autofill your login item by clicking the 1Password icon on the top right corner of your browser and selecting your login item there.

    We are also looking into toning down 1Password's suggestions to make it less intrusive. In the meantime, if you'd like, you can right-click 1Password's extension icon in the toolbar and select "Settings" -> Turn off "Show autofill menu on field focus". That will tone it down for you.

    Sorry for the inconvenience :+1:

    ref: dev/core/core#9970

  • I'm not sure I understand what's going on in my situation. I have logins with Yahoo and others with Gmail. Autofill is on. So why does 1P choose Yahoo instead of Gmail, especially since Gmail is the correct login for NYT? Even if it's a page to login or create an account, why suggest Yahoo and not Gmail? I think most sites offer the option to login or create an account, so why doesn't 1P ever offer Gmail? Shouldn't a dropdown menu offer a choice?

  • ag_chantelleag_chantelle

    Team Member

    @jimmyweg

    This appears to be a bug on our end. It looks like 1Password is suggesting your Yahoo email address, from an Identity item, instead of your actual Login for NYT. I see that Jack has reported this to our development team to see if we can get this fixed up for you.

    In the meantime, if you wish to autofill your NYT credentials, I would suggest clicking the 1Password icon in your browser toolbar and choosing Autofill from there. I realize this is not ideal, but should achieve what you're after. I apologize for the extra clicks here.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file