Support Needed - Update Broke Browser Extension

mitchcbrmitchcbr
edited October 14 in 1Password in the Browser

I'm super frustrated with 1Password today....bear with me, this is long.

I really dislike the auto-generated 'suggested' passwords the browser extension provides. I sometimes need 1-time use temporary passwords for work, and the suggested ones are too long. Therefore, I often will open up the full app, create a new login item, generate a password, copy it, cancel out of login item creation, "don't save"...this process sucks. I read on a forum post that newer versions of 1P may allow them to be shortened.

I updated 1P to the latest version. Now my browser extension isn't working. Clicking the 1P logo at the top of Safari does nothing. When on a site with a login, I see the 1P logo in the form, and a box with a blue 'Unlock 1Passsword' button pops up; it also does nothing. I've tried restarting 1P and Safari to no avail.

^ This is the main reason for me contacting support.


Also unrelated but annoying:

I logged into the 1P site to request help. I clicked on the email option for support. I filled out the form but received no email confirmation. I'm really not sure if it went through. Looking more closely, I saw that my 1P login did not carry over into the email form.

Therefore, I went to make a Community post. I also see that my login does not carry over here. I'm required to create a new login, separate from my 1Password account. So 1Password requires me to create a separate set of credentials to obtain support. (Oh, the irony.)

After filling in the form to create a new login for support, my browser automatically redirects and tells me 'Permission Problem: You don't have permission to do that. You need to confirm your email address...' First of all, I didn't try to do anything; it was automatic. I get that I have to confirm my email, but this has been a crappy experience from the start.


1Password Version: 7.8.8
Extension Version: Not Provided
OS Version: Big Sur 11.6

Comments

  • ag_anaag_ana

    Team Member

    Hi @mitchcbr!

    We will be happy to help you with this. I noticed that you also sent us an email with the same question. So we don't duplicate the answers by replying to you in multiple places, I am going to close this forum discussion and someone will get back to your email as soon as possible.

    Thank you for your patience!

    ref: KKA-17633-979

    Therefore, I went to make a Community post. I also see that my login does not carry over here. I'm required to create a new login, separate from my 1Password account. So 1Password requires me to create a separate set of credentials to obtain support. (Oh, the irony.)

    Indeed, the 1Password.community and the 1Password.com main service are kept on two separate websites on purpose for security reasons, so they require two separate logins. Just imagine if the forum had any issue and the credentials were somehow compromised, an attacker could use them to login to your 1Password account too. Yikes!

  • mitchcbrmitchcbr
    edited October 15

    @ag_ana this is in regards to https://1password.community/discussion/comment/615707.

    Apparently I fat-fingered my email address, as I've not received any email communication. This would also explain why I didn't receive a confirmation.

    In any case, as co-worker pointed out the 1P background service running in the menu bar, with the option to 'Quit 1Password Completely'. I closed that service, restarted my browser, restarted 1P, and now it's working.


    1Password Version: Not Provided
    Extension Version: Not Provided
    OS Version: Not Provided

  • ag_anaag_ana

    Team Member

    @mitchcbr:

    Apparently I fat-fingered my email address, as I've not received any email communication. This would also explain why I didn't receive a confirmation.

    Do you mind checking your spam folder?

    In any case, as co-worker pointed out the 1P background service running in the menu bar, with the option to 'Quit 1Password Completely'. I closed that service, restarted my browser, restarted 1P, and now it's working.

    Thank you for sharing this! I am glad to hear that things are working once again :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file