How to properly migrate from US to EU vault, including attached files?

edited October 26 in Memberships

I created a new account for eu, added it to 1password, but when I try to copy the items over I'm getting "Items with files can't be moved from an account on a server to another".

It's also not possible to do a full export and re-import a backup into the new installation, so what is the proper way to actually do this?

/EDIT: To my surprise, from the looks of it, it's not possible to do anything with items with file attachments. I can't copy them to any other vault, I can't move them, and when I export all items in 1p interchange format, items with file attachments aren't included either.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided

Comments

  • edited October 26

    Okay I had an idea and wanted to be smart about it: Import everything into my iCloud vault and just start the migration to 1p.com from scratch again.

    Well apparently you can't copy items with file attachment from 1p.com -> iCloud vault either. You can do iCloud vault -> 1p.com but not the other way around, what gives?

    I'm a bit spooked about complete lock-in into the 1p.com version if I can't get my items with attachments out and into some kind of backup.

    My original question was about migrating from US to EU but I'd like to expand: How can I actually download all my items including all attachments to a local vault? Are they included in the automatic backup that the Mac app does regularly?

  • ag_anaag_ana

    Team Member

    Hi @ordinarybeef!

    /EDIT: To my surprise, from the looks of it, it's not possible to do anything with items with file attachments. I can't copy them to any other vault, I can't move them

    When you move items with attachment from a standalone vault to a 1Password.com vault, attachments should be converted to Document items automatically. Is this not happening for you? Are you getting an error message that tells you those items cannot be moved at all?

  • @ag_ana previously that was the case but now that 1password.com finally supports inline attachments, attachments just end up staying attachments in standalone and 1password.com. The only thing is that you can't copy from 1password.com -> standalone, or 1password.com -> 1password.com in a different region

  • ag_anaag_ana

    Team Member

    @ordinarybeef:

    Thank you for the clarification, I think I understand the scenario now. There is currently a known limitation when it comes to moving documents or exporting them, in the sense that this does not happen automatically like when you move other items between vaults or between accounts. Our developers are aware of this and will hopefully have a solution soon, but in the meantime you will have to save a local copy of the document manually (you can do this by clicking on the attachment or document item directly in the app). At this point you can upload the document again in the new account.

  • edited October 27

    Thanks @ag_ana

    Doing it manually is not a solution for me because I'd have to go through multiple hundred of items 1-by-1 just to download their attachments and re-upload them.

    It's good to hear the team is aware of this. I hope the solution will also include support for copying from 1password.com -> standalone, and a way to include attachments in 1pw exported files + backups (please don't leave out standalone for this). I'm getting a bit anxious that my file attachments are locked in 1password.com without a way for me to get them out that doesn't involve 1-by-1 going through each item to download it.

  • ag_anaag_ana

    Team Member
    edited October 27

    Understood @ordinarybeef, in the meantime I have let the developers know that you would need this feature too :+1:

    ref: dev/projects/customer-feature-requests#560

    Just to make sure I mention every possibility though, there might be an alternative if you know how to code: our CLI has some tools to work with documents already, and it looks like it already allows downloading them:

    To download a document and save it to a file:

    op get document [--vault ] [--output ]

    If you have hundreds of them, perhaps this could work for you.

  • To download a document and save it to a file:

    This again looks like it's dealing with the old document format when documents were separate things, not when they are embedded into the item itself.

    I'll give it a try and see how it goes.

  • All right I tried the CLI. Embedded file attachments are still handled internally as "documents" from what I see, but the CLI doesn't work with them.

    Here's an example:

    op get item "My Item" | jq

    Tells me under 'fields' that one field is a document. Copying the documentId out and using it with

    op get document <documentID>

    is giving me [ERROR] 2021/10/28 11:12:15 "<documentID>" isn't an item in any vault.

    So sadly it still doesn't look like it's possible to extract my attached files back out :/

  • ag_anaag_ana

    Team Member

    @ordinarybeef:

    Thank you for the update. I will check with the developers if they have any insight into this :+1:

  • ag_anaag_ana

    Team Member

    @ordinarybeef:

    I have heard back from the developers: I confirm that at the moment the CLI can only view an attachment, but it cannot download it yet. I was also told that the developers are aware of the request though, so hopefully this is something they can add in a future update of the CLI :+1:

  • Thanks for the update!

    I wanted to check about the core question again - how can I effectively migrate my vault to EU when I'm currently not able to move my files out? Is this something that's just not doable currently?

  • ag_anaag_ana

    Team Member

    It is possible, but only by downloading attachments manually at the moment @ordinarybeef, and uploading them to the new account, until the developers add this capability to the app directly.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file