Cannot install Safari extension

Hi,

I am using 1Passoword 8 Early Access and was trying to install 1Password for Safari on my new Mac. I have installed version 2.1.3 of 1Password for Safari but cannot get Safari to add the extension.

After I open 1Password for Safari I see the window that explain how to add it to Safari but clicking "Open Safari Preferences" does not open Safari. Somehow it does not find my Safari or something else is causing this...

I have successfully installed 1Password for Safari on my old MacBook and my work MacBook so I do not know why it does not work on my new Mac.

Thanks for your help in advance.


1Password Version: 8.4.0
Extension Version: 2.1.3
OS Version: 12.0.1

Comments

  • I just tested another Safari extension I have installed and this one does correctly open Safari Settings after I click on "Open Safari Peferences".

  • ag_anaag_ana

    Team Member

    @JohnnyFJohnsson:

    Thank you for the update :+1:

    In case someone else stumbles upon this discussion, the Safari extension that works with 1Password for Mac 8 Early Access is this one.

  • Hi @ag_ana,

    thanks for the reply and the link. I am using that version of the extension but it does not work.

  • ag_anaag_ana

    Team Member

    @JohnnyFJohnsson:

    In your previous post you wrote this:

    I just tested another Safari extension I have installed and this one does correctly open Safari Settings after I click on "Open Safari Peferences".

    So I understood that things were working for you now, but your latest message suggests otherwise. Can you confirm?

  • edited October 29

    @ag_ana Sorry. I did not make that clear. I tested if a completely different extension works with my Safari. In this case I tested with the DuckDuckGo Privacy Essentials extension and that correctly opened the Safari settings and installed.

    The 1Password extension does not open my Safari when I click on "Open Safari Preferences" and therefore does not install. But I do not understand why. On my work MacBook the same 1Password for Safari extension version does correctly open my Safari, is installed and confirmed working.

    So I assume it has to do something with my new Mac but removing the Safari extension and re-downloading it did not help. Do you have any other tips?

  • ag_anaag_ana

    Team Member

    @JohnnyFJohnsson:

    Thank you for the clarification! If you open Safari Preferences manually and go to the Extensions tab, do you see the extension in the list there? If you do, can you enable it by clicking on the checkbox next to it?

  • @ag_ana unfortunately I do not see it in in the Safari Preferences.

  • Hi @ag_ana, I have reinstalled MacOS as somehow also my iCloud Drive was not fetching any files so something must have messed with my configuration. Now the Safari browser extension works again. Thanks for your help even if the error was on my side.

  • ag_chantelleag_chantelle

    Team Member

    Great to hear things are working again for you @JohnnyFJohnsson! :smile:

  • I ran into this today. I already had the extension and had been using it without issue, but it seemingly disappeared overnight. Quitting Safari, reinstalling the extension, and rebooting the computer all did not help.

    I remembered reading something similar a little while ago and dug it up: https://lapcatsoftware.com/articles/disappearing-safari.html

    I ran this in Terminal.app, as the article suggested:

    /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -f -R /Applications/Safari.app
    

    and it fixed the issue for me! Hopefully this helps anyone else who starts seeing this problem :smile:

  • ag_chantelleag_chantelle

    Team Member

    Thanks for chiming in @klanchman! Glad to hear the terminal command helped with registering 1Password in Safari for you again. :+1:

  • gompygompy Junior Member

    Thanx, fixed it for me also!

  • ag_chantelleag_chantelle

    Team Member

    Great to hear @gompy! :smile:

  • Fixed for me as well. I removed the app and reinstalled several times (both 1Password and 1Password for Safari). Agilebits may want to look into why removing/reinstalling isn't fixing the issue by itself - it shouldn't take doing that in the terminal to unblock enabling the extension. Thanks klachman.

  • I encountered the same issue - extension disappeared for seemingly no reason overnight and I could not get it to appear again in the extensions menu of safari preferences. Running the terminal command above solved the problem.

  • Hey @joshuacale and @avery_shealey:

    Glad to hear that worked for you. As mentioned in the link @klanchman posted, this doesn't appear to be specific to 1Password. We've reported this issue to Apple for further investigation, but for now, our best recommendation is the terminal command as needed. Thanks for your patience on this!

    Jack

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file