New 'Hide my Email' box blocks the 1Password popup in Safari (macOS Monterey)

agent177agent177
edited November 2021 in 1Password in the Browser

With 'Hide my Email' enabled, this frequently blocks the 1Password popup in Safari when signing up for a new account - see the screenshot, for example. Is there anyway to move the 1Passoword box out of the way?


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided

Comments

  • Hi @agent177:

    We'd recommend disabling Safari's AutoFill to avoid conflicting in these kinds of situations.

    Jack

  • I'm disappointed that this is the suggestion. I know that 1Password recently released the "Masked Email" feature, but it only works if I'm a FastMail paying subscriber. I don't pay or use FastMail, but I do pay & use iCloud so I get this same feature. Is there a way to make the Safari extension work with the Hide My Email popup?

  • ag_yaronag_yaron 1Password Alumni

    Hey @traviscook21 ,

    Currently we only support Fastmail. If you'd like to keep utilizing both 1Password and Safari simultaneously, you can dismiss this popup with the ESC key on your keyboard, then click the little 1Password icon on the right corner of the field to bring up 1Password's suggestions.

    However, as jack.platten mentioned above, we do recommend disabling the browser's built-in autofill features as 1Password was not designed to work alongside other autofilling apps or features of the browsers.

  • Dismissing the popup with the ESC key does not actually work, in my experience. Is there some other setting that needs to be adjusted in order to do that?

    (I understand 1Password's preference that we disable other autofill features, but to that I'll just say that the more 1Password requires me to disable other features and to use it exclusively, the less likely I am to remain a customer.)

  • jack.plattenjack.platten

    Team Member

    Hey @wjjwj:

    Thanks for asking! If you'd like to manually invoke the 1Password in-line menu as necessary, while allowing for Safari's email address in-line menu to show up disabling "Show autofill menu on field focus" would be your best bet. To do this follow these steps:

    1. Right click on the 1Password icon in Safari's toolbar > Choose Settings
    2. Disable the option under General named "Show autofill menu on field focus"

    Let me know how you get on with that!

    Jack

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file