Cannot get to 1Password dialog in email fields on Safari with macOS Monterey

Cannot get to 1Password dialog easily...

Website was https://signon-service-now.com but happens on many sites in an email field for login


1Password Version: 7.9.1. Beta 5
Extension Version: 7.9.1. Beta 5
OS Version: macOS 12.0.1

Comments

  • I should add that I haven't changed any of my browser settings, but I did go from macOS Big Sur to macOS Monterey this morning. This new 'Hide My Email...' thing comes with iCloud+ I think. It's their private relay service.

  • ag_anaag_ana

    Team Member

    Hi @Critch!

    In Safari Preferences > AutoFill, do you have any of the options “Using info from my contacts”, “User names and passwords”, “Credit cards”, and “Other forms” enabled?

  • Yes, I have the following enabled but I didn't change any of this. I presume this is how it was set before the upgrade to macOS Monterey...

  • It looks like the 'Using information from my contacts' option is the culprit. I just disabled that one alone and the issue seems to have gone away. I swear I didn't change any of these settings, so it must have been enabled my the macOS upgrade process?!

    Thanks for your help

  • ag_anaag_ana

    Team Member

    @Critch:

    I swear I didn't change any of these settings, so it must have been enabled my the macOS upgrade process?!

    That would be my suspicion :+1: In any case, I am glad to hear that everything is sorted now :)

  • sachasacha Junior Member

    Hi! Thanks for the tip. I was also annoyed about this. Anyway this is a workaround for the issue, and I suppose 1Password should tackle with it as more users will be also annoyed as this is default for Monterey.
    1) Help or tips when installing or upgrading 1Password would be great
    2) Maybe changing the dialog's size or position? What if I want best of both worlds?

    Thanks and keep the good work going on!

  • ag_anaag_ana

    Team Member

    @sacha:

    Generally speaking, our recommendation is always to turn off the feature in the browser, if possible:

    Turn off the built-in password manager in your browser

    We will keep an eye out for the behavior on Monterey however, and see if there is anything we can do here to improve the experience in case this happens to someone else :+1:

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file