Broken Shortcut (ctrl+-)

Hi,

Pretty simple, I've noticed a problem with the zoom out shortcut ( ctrl + - ) not working in the current version (I think it affected the previous release too but I didn't have time to figure out the problem).

Now in an of itself this isn't a big deal as I never use this shortcut in 1Password, but on my Pop_os machine which uses Xorg this bug effectively prevents me from using the ctrl+- shortcut in every single application! So I'm unable to resize text in my terminal, browser etc. unless I quit the 1Password application.

I've tried this in Pop_os 21.04, 21.10 and Fedora 35 (in a VM) with the same results. (Though in Fedora which uses wayland the shortcut is broken but due to how wayland works it doesn't interfere with any other applications so it's not nearly as bad).


1Password Version: 8.4.0
Extension Version: Not Provided
OS Version: Pop_Os 21.04, 21.10, Fedora 35

Comments

  • Mathieu_1PMathieu_1P

    Team Member
    edited November 22

    Thanks for writing in Dru. This is not how we expect this to work. Would you mind sharing what keyboard layout you are using to help us track down potential causes for the behaviour you are experiencing?

    Also, could you try removing all the keyboard shortcuts in the 1Password settings and see if the problem still occurs (this is not a proposed solution but might help us eliminate a possible cause)?

  • Thanks Mathieu.

    Here's my keyboard layout:

    % setxkbmap -query                 
    rules:      evdev
    model:      pc105
    layout:     us,gb
    variant:    ,
    options:    caps:ctrl_modifier
    

    After removing the keyboard shortcuts it appears removing the ctrl+\ shortcut fixed things.

  • Mathieu_1PMathieu_1P

    Team Member

    Thank you for the additional information Dru. This looks like it might be the same root cause as a few other issues that have popped up recently. I can't commit to a timeline but this issue has the attention of many developers and hopefully one of us will have the time to fix it soon.

  • That's great, thanks! I can live with the temporary workaround of unbinding the shortcut on my Xorg machine in the meantime.

  • PeterG_1PPeterG_1P

    Team Member

    Hi @dru, thanks for the update. It's great that you've established a workaround, and our developers will be taking a look at keyboard shortcut behavior going forward. Thanks for letting us know of what you've seen here!

    ref: dev/core/core#7697

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file