1Password on Mastodon

Shortcut to fill password in browser not working on German QWERTZ keyboard layout

TundorTundor
Community Member
edited November 2021 in Windows

Hi there,

first off, I really love 1password and I was delighted to be surprised by a brand new windows version, thanks for that :)

Unfortunately, my standard shortcut to fill the passwords in my chrome browser is not working anymore. In the previous version, I was using the shortcut "Ctrl + #" (where as "#" is the equivalent position on a german keyboard layout to the "\" on a US layout, so this is essentially the default setting). In 1password 8, this suddenly stopped working and I have the suspicion that those keys are not properly mapped with the german layout anymore.

Here's how my configuration for the shortcuts in the settings look like:

I tried to re-assign the shortcut, but pressing Ctrl + # on my keyboard will always just add "Ctrl + \" in the configuration. If I use this shortcut in the browser, it never fills a password. I assume the mapping of the keys is different from what it adds when setting it in the configuration vs. how it maps the keys when I actually execute the shortcut in the browser. If I set the shortcut to a key which is not ambigous inbetween the two keyboard layouts (for instance Ctrl + 5 on numpad) the shortcut works in the browser and the passwords will be filled.

I hope I managed to explain the problem somehow comprehensive as I'm not a native speaker. If you need any further information from my side, I'm happy to give more insights. Any help is appreciated

Thanks


1Password Version: 8.4.0
Extension Version: 2.1.4
OS Version: Windows 11

Comments

  • viswizviswiz
    Community Member

    This is an issue with all non English keyboard layouts. It was reported numerous times by several users during early access. But sadly it's still not fixed.

  • TundorTundor
    Community Member
    edited November 2021

    Thank you, that's very unfortunate as it really spoils my workflow experience :( I hope this is going to be fixed soon. Worst case, is it possible to roll-back to the previous version or won't this work anymore?

  • PeterG_1PPeterG_1P

    Team Member

    Hi @Tundor , sorry to hear of this issue. You can indeed revert to 1Password 7 - and @viswiz is correct, this keyboard layout didn't make the initial release but we'll be working on that going forward. Our apologies again for the disruption here, and we'll work to support this layout as soon as we can.

    ref: dev/core/core#7697

  • tsauertsauer
    Community Member
    edited November 2021

    This is super frustrating. It was reported multiple times during early access and now even with the final version it's not fixed. Also reverting to 1Password 7 is a not an acceptable workaround since 1Password 7 on Windows is a horrible experience to begin with (only opens half of the time, constantly crashes, it's super laggy, struggles with high refresh monitors, etc.)
    The whole experience is so frustrating in comparison to the MacOS version to a point where I feel like Windows customers are not appreciated at all.

  • PeterG_1PPeterG_1P

    Team Member
    edited November 2021

    Hi @tsauer , I'm really sorry to hear this, and can understand the frustration with the German keyboard layout issue. All I can offer at this point is that our developers are aware of it and it's slated for improvement.

    We do think that 1Password for Windows 8 is a huge leap beyond 1Password 7. 1Password for Windows also came a long way throughout Early Access, and the improvements will keep coming even beyond the landmark of this 8.4 release. This is not the final state of 1Password 8, but we are proud of what we've got - especially given the advances over the previous generation - and will work to keep iterating further yet.

    The whole experience is so frustrating in comparison to the MacOS version to a point where I feel like Windows customers are not appreciated at all.

    I'm sorry to hear this as well. We really are doing our best to support each platform, and to do so in a way that honors the strengths of each platform and uses each of them to their full potential. You'll have to be the judge of how successful we are at that, of course, and we promise to do our best to impress you at every turn.

  • viswizviswiz
    Community Member

    @tsauer although my main OS is macOS I'm as upset as your are about releasing a pretty much unfinished version of 1PW8. Once or twice a week I come back to my test installation of 1PW8, happily updating to its latest version just to find out that nothing has really changed. The shortcuts dialog still doesn't work with non US keyboards, search is completely broken, ...
    In the past the macOS version might have been a first class citizen but this ended in the most brutal way I could imagine with version 8. We now get an "emulated", fake, custom UI that doesn't even respect the most basic UI principles of macOS. So I have to highly disagree with @PeterG_1P regarding:

    We really are doing our best to support each platform, and to do so in a way that honors the strengths of each platform and uses each of them to their full potential. You'll have to be the judge of how successful we are at that, of course, and we promise to do our best to impress you at every turn.

  • SecretarySecretary
    Community Member

    I just went back to 1password 7, because 8 isn' usable for me as a german user without the shortcuts.

  • kalantheskalanthes
    Community Member

    I have the same issue and found the cause/workaround.
    It is the wrong keyboard setting used in 1P8. It is for both "show 1Password" and for "fill in browser":

  • nicofurlanicofurla
    Community Member

    Hi,
    same problem here with Italian keyboard layout, so as someone wrote before, it'as problem with all non US layouts and not related to locale settings (any choice you set for locale seems not to affect keyboard custom shortcuts input).
    Furthermore, the application tray icon menu items are in English no matter what the locale setting is and for some keyboard combos, the shortcut displayed reflects the local keyboard layout, being different from the one displayed in the application preference settings (i.e. you set ctrl-shift-à to open 1Password and in the app becomes ctrl-shift-' but in the tray icon shows as ctrl-shift-à; this last is the actual working shorcut).
    Hope in a quick fix.

  • Jack.P_1PJack.P_1P

    Team Member

    Hi @kalanthes and @nicofurla:

    I've added both of your feedback to the issue Peter referenced above. Thanks for your patience, and keep an eye out for improvements!

    Jack

This discussion has been closed.