Autofill in Safari fails on an increasing number of websites

cortigcortig Senior Member

I never had that issue with 1Password 7, but now with 1Password 8 and the 1Password for Safari app/extension, more and more sites seem to be incompatible with Autofill.
Here are a couple of examples:
https://subscribe.free.fr/login/
https://umhealthresearch.org/login/index.html#volunteer

Not quite sure what’s going on, but the Autofill button simply does nothing on these pages.


1Password Version: 8.5.0-37.NIGHTLY
Extension Version: 2.1.4
OS Version: macOS 12.0

Comments

  • Hi @cortig:

    Thanks for reporting this. I've just tested on both, and after fully restarting my MacBook, I had no issues with using the Autofill button in the pop-up on either of these sites. Would you mind restarting your Mac just to confirm if that fixes it for you? If that doesn't fix it, I'd be happy to investigate further with you. Thanks!

    Jack

  • cortigcortig Senior Member

    I restarted the Mac and the issue remains. And at the same time, many other sites are just fine, so it’s not a systematic issue. I wonder what’s wrong.

  • Hey @cortig:

    Thanks for the update. Just as a test, if you create a new Login entry by copying the information into the username and password field of the website, then using the inline menu to save it as a new Login, does the Autofill button work then? Let me know!

    Jack

  • cortigcortig Senior Member

    So here’s the thing: I wasn’t getting the inline menu in the fields at all…
    I played around with the entries in 1Password, I duplicated the corresponding item in the vault and eventually rebooted again and this time, I got the inline menu, the login popping up and autofilling for both sites.
    Something was obviously off, but at this point I’m not sure what corrected it :-( And the weird thing was that it was only affecting a few random sites (but always the same ones).

  • @cortig:

    Glad to hear you fixed it. If you do run into any issues in the future, let us know and we'll be happy to take another look!

    Jack

  • cortigcortig Senior Member

    It’s really weird. I tried https://subscribe.free.fr/login/ again today and it wouldn’t auto-fill anything.
    Then, maybe an hour later, it started offering login options again.
    There’s still something quite off.

    Corentin

  • Hey @cortig,

    Thanks for updating us, and I'm sorry you're still running into issues with 1Password on this page. To take a closer look at what could be going on, can you please collect a console log from 1Password for Safari the next time you run into issues on that site: Save a console log for 1Password in your browser

    After collecting the console log, please attach it in an email to [email protected] with a link to this thread, and we'll be able to take a closer look at what could be happening here. After emailing, you should receive a response from BitBot with a support ID that looks like this: [#ABC-12345-678]. Post that here and I'll be able to link the conversations together. Thanks again for your patience on this!

    Jack

  • cortigcortig Senior Member

    Sent!

    AII-18977-962

    It’s interesting: I tried on the free.fr website and it worked fine. I then opened up a new window and tried again and this time it failed…

    I also added one more site where autofill fails (and seems to fail systematically) in the email.

    Corentin

  • Hi @cortig,

    Thanks for that, we'll take a look and see what we can discover!

    Jack

    ref: AII-18977-962

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file