SCIM Bridge test

Hi,

We are trying to setup a SCIM bridge to 1password using Azure for the bridge and provisioning.

We have got to step 4 of the setup which is 'Test the SCIM Bridge' but this isn't working

curl --header "Authorization: Bearer " https://WEBADDRESSES/scim/Users (with the bearer token replacing < bearer_token > and WEBADDRESS being our domain we set) returns the following error

Invoke-WebRequest : A positional parameter cannot be found that accepts argument 'Authorization: Bearer XXXXXXXXXXXXXXXXXXXXXX'

I can't figure out how to get this working, removing the argument of Authorization: Bearer and running the following command:

curl https://WEBADDRESSES/scim/Users

give us the following error:

curl : {"detail":"401 (Unauthorized)","schemas":["urn:ietf:params:scim:api:messages:2.0:Error"]}

Browsing to domain we setup does give us the correct the login and using the bearer token show us the following screen

Do we need to confirm the SCIM has access and shows the users currently residing in 1Password before we continue?

Thanks in advance!


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided

Comments

  • Hello. Thanks for writing in.

    Given the Invoke-WebRequest in your error message, can I assume you're using PowerShell?

    If so, then you'll need to use PowerShell-compatible syntax to complete this testing phase.

    Invoke-WebRequest -Headers @{"Authorization" = "Bearer BEARER_TOKEN"} -Method Get https://your-scim-url.example.com/scim/User
    

    Replace BEARER_TOKEN with the token you've used before.

    The test is technically optional, however, especially if you've been able to log in to the SCIM bridge web UI using the bearer token, which performs a similar test. You could also continue on to configure your Identity Provider at this point.

  • Hi, thanks for coming back to me.

    I tried that but still get an error, this time the command is: (with the token and web address updated to ours)

    Invoke-WebRequest -Headers @{"Authorization" = "BEARER_TOKEN"} -Method Get "https://our-scim-url.example.com/scim/User"

    The error message is:

    Invoke-WebRequest : {"detail":"Not found","schemas":["urn:ietf:params:scim:api:messages:2.0:Error"]}

    I'll carry on with the documentation and try and get the enterprise app setup and see if it imports users.

  • Hi @DougWalker.

    Thank you for your reply. My apologies, but there is a slight typo in the URL that we shared with you earlier.

    GET https://your-scim-url.example.com/scim/User

    Should actually be:

    GET https://your-scim-url.example.com/scim/Users

    Note the s at the end of users.

    Can you please give that a try and let us know if it works?

  • Ahhh that was it thanks! I should have tripled checked it myself.

    Thank you for this, our trial ran out on Monday evening and we are currently waiting for the purchase to be completed by procurement so I can't progress with this but hopefully in the new year I can finish it off.

    Thanks again for the assistance.

  • No problem. Glad we could help! Please don't hesitate to reach out again.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file