New password not accepted

Hi there

2 member family account, my wife tried to set up 1pw on her MacBook and got stuck. She did not write down her master pw, did not print the emergency thing, and now asked me to set up her computer. Because I have no account details, I ran through the recovery process. Seems to all work, and I can log into 1pw from the website using the new password.

The problem starts with 1password 7 for Mac, and the browser extension. Neither one accepts the new password. The login thing shakes back and forth, turns red, and says "Your master password is required to use touch ID".

I've run through the recovery process twice with the same result, not sure what I am doing wrong


1Password Version: 7.9.2
Extension Version: 2.1.4
OS Version: MacOS Big Sur 11.4

Comments

  • More information: in the preferences in the 1pw app, under accounts, it seems like it has a different secret key. I think if I can clear that account information, it could be re-loaded, but it doesn't let me remove it. I've tried uninstalling the app and that doesn't help.

    How do I reset the account information?

  • Alright, found another piece of the puzzle - instructions on how to uninstall 1pw: https://support.1password.com/uninstall-1password/

    After restarting and re-installing the app for the 5th time, it finally asked for account information and it let me log in at last.

    Really, as a user I should not have to browse to system folders to manually pick pieces to delete.

    Three things:
    1 - there should be a function to clear/reset account information
    2 - the "add your account directly" function under 'get the apps' should actually work, and update the account information from the website into the app
    3 - Uninstalling the 1pw app should include getting rid of the data automatically

    As a bonus, it should really be much easier to find this information, for instance a link to the community from the home page?

  • 2 member family account, my wife tried to set up 1pw on her MacBook and got stuck. She did not write down her master pw, did not print the emergency thing, and now asked me to set up her computer.

    LOL I just posted a thread asking about a similar imaginary scenario. One of my concerns as I am evaluating moving to 1PW is a family member that shall remain unnamed that has a propensity for similar to your wife [no offense intended :-D] and I am very concerned about how they would access 1PW if something happened to me and they could not find their secret key.

  • Dave_1PDave_1P

    Team Member

    Hello @DenSter and @PasswordSchmassword! 👋

    @DenSter:

    I'm sorry for the frustration that you've experienced, it sounds like something went wrong after the recovery process on the Mac side. User data is stored separately from the app which is why uninstalling the app doesn't remove your 1Password data, this is done to prevent data loss.

    I'm happy that you were able to resolve the issue. In the future you can certainly reset the 1Password for Mac app without having to go manually remove 1Password folders. Here are the steps:

    1. Reset 1Password for Mac: How to reset the 1Password app on a specific device
    2. Add your 1Password account back to the 1Password for Mac app: How to add your 1Password account to the apps

    @PasswordSchmassword:

    I recommend that your family member download and save their Emergency Kit. They can print out the Emergency Kit and write down their account password. Then they can store the Emergency Kit in a personal safe or somewhere else where it will be secure.

    I hope that helps. :)

  • Hi Dave, thanks for the reply. Kind of ironic that this could have been prevented if only we had written down the password on a piece of paper. By the way, when we did recover the account, her old password was still in her private vault, which you can only get into if you know the password.

    Very clear that "something went wrong", but there should be an action in the app to clear/reset/refresh/edit account information. As stated above, the option to directly load the new data from the website into the app did not work, it kept the old/invalid data in the app. That link where it explains how to add an account, that did not work either, it would not let me either remove or add an account. Both the '+' and '-' buttons were disabled with the old/invalid account information stuck in the app.

    repro scenario: on a mac, get an account all set up, and then do a recovery and try to directly reload the new info into the app. It simply does not work properly.

    Just to be totally clear: I don't blame my wife for "messing up". She's actually pretty savvy technically, but even a computer illiterate should be able to clear this data without having to go into system folders to manually delete obscure data. This is a flaw in the system and should be fixed. Also, removing user data should be part of the uninstall process. Also, deleting old/obsolete user data should be part of the install process. If you're worried about losing user data, add a confirmation message "found some old data, wanna keep that?" and then fix the software so that the user can actually edit account information.

    Anyway, rant's over. It works for now, like I said I figured it out myself yesterday. Hope this thread will help someone in the future

  • Dave_1PDave_1P

    Team Member
    edited January 6

    @DenSter Thank you for the feedback and for the thoughtful reply. I'm sorry again for the frustration.

    I know that you've already resolved the issue using a different method but you mentioned that you were unable to reset the 1Password app. You should be able to reset the 1Password for Mac app so that you can start over without uninstalling it. Can you confirm that you tried the following steps (based on the article that I linked in my previous post):

    1. Open 1Password for Mac (you don't need to unlock the app using your password).
    2. Click on Help.
    3. Click on Troubleshooting.
    4. Click on Reset All 1Password Data.

    I look forward to hearing from you. :)

  • DenSterDenSter
    edited January 6

    Hey Dave, I did not try that method, the problem was already resolved. When the add/remove account buttons were disabled in the accounts section I figured "something went wrong" and I uninstalled the app. Good to know that the app does have this option though, that actually makes me feel a lot better about it so thanks for pointing that out again. If this happens again I will definitely try that but right now it all works and I don't want to rock the boat so to speak. I just read back my previous comment and it sounds a lot more snippy than I meant it.

    Would be great if that action were available in the accounts section, or if there were some text in the caption where to look for that option. I went back to the uninstall instructions and noticed that there is a link to the removal post that I have to admit that I totally missed. The account data not refreshing from the website is still an issue though, someone should look at that.

    BTW that looks like a great bike ride in your avatar pic

  • Dave_1PDave_1P

    Team Member

    @DenSter Thank you again for the feedback, our developers are discussing how to better implement resetting the app in the next version of 1Password for Mac and hopefully we can make improvements here. :)

    In the meantime, for anyone who stumbles onto this thread in the future, our recovery guide includes a paragraph on resetting the app if a user is unable to unlock 1Password after a recovery: Recover accounts for family or team members

    BTW that looks like a great bike ride in your avatar pic

    It was a nice bike ride! My profile picture is from my visit to a park in Quebec, Canada named Parc national de la Pointe‑Taillon.

    ref: dev/core/core#7378

  • edited January 16

    I'm experiencing the same problem. The mac app is not accepting the master password that the website and iOS app is accepting. This renders the Chrome extension useless, too, because the extension is just trying to open the mac app.

    But there is no option to reset the mac app data as discussed above, because the login screen does not show anything other than the login itself. There is no help button. No menu. Nada. @Dave_1P

    I have tried a new master password. Nope.
    I have tried a new Authenticator app. Nope.

    Going on several hours after switching our team from LastPass.

  • Update: I successfully uninstalled the mac app using Denster's advice above. I removed the chrome extension and re-added the extension, and it's working great. So... the moral of the story is... don't use the mac app.

  • Dave_1PDave_1P

    Team Member

    @lostin1pass I'm sorry to hear that you're having trouble resetting the 1Password for Mac app. Even when the 1Password app is locked you can find the Help menu item at the top of your screen:

    What did you see at the top of the screen in the menubar after clicking on the 1Password app's lock screen window?

    That being said, I'm happy that it sounds like you were able to resolve the issue that you were running into on your Mac using another method. :)

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file