Bitwarden Export and import to 1Password [Solved]

TheMadCowTheMadCow
edited January 7 in Mac

I have downloaded the the most recent build of @MrC converter. I've tried this on both the webversion and the latest desktop v1.30.0 and it's giving me grief. Bitward is exporting an empty .csv file. The .json has data, so I process that through the converter. Terminal reports that nothing was imported and produces an empty .pif file. I realize that the .csv issue is probably a Bitwarden thing, so I'll hit them up on this, too. Thanks.


1Password Version: 7.9.2
Extension Version: Not Provided
OS Version: 10.14.6

Comments

  • This is the debug output for the .json file.

  • MrCMrC Community Moderator

    @TheMadCow

    Hey MadCow, sorry for your troubles. The bitwarden converter only accepts JSON, so let's ignore the CSV issues (and yes, the 0 byte export would be their issue).

    If you enable verbose output in the converter using the -v option, do you see any results? And how about with the debug option -d. What happens then (this output will contain sensitive data).

  • Not saying anything new.

  • MrCMrC Community Moderator

    @TheMadCow

    That JSON file only contains 56 bytes, and that doesn't seem like much data. You can look at the contents - it's a plain text file.

    Does the export contain what you were expecting?

  • Doh, you're right. Appears to be borked on .json exports, too. The vault in question only has about 20 entries. This is what is showing:
    {
    "encrypted": false,
    "folders": [],
    "items": []
    }

  • MrCMrC Community Moderator

    @TheMadCow

    I looked at the BitWarden GitHub site and didn't see any recent commits that would cause the issue (but I didn't look carefully, or deeply). No issues reported, nor commits that might have changed JSON / CSV exports.

    Within the past 30 days, I've exported from BitWarden (on Windows) to add some code to the converter for another user, and know it works. I wonder if there is something with your data, or something about how you are exporting, that is creating the issue?

  • Wacky. I was added as an admin to the company account (user was leaving) and I had all access. But the export thing. Mashing around I see that it's also an organizational account, too. So I click on the company organization. Presents the same. But from that I exported again and it worked. Odd. But huge huzzahs for the utilities. Imported (finally) like a charm. Thanks for the response.

  • MrCMrC Community Moderator

    Outstanding, @TheMadCow .

    You're welcome, and have a great weekend.

    Enjoy 1Password!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file