Familysearch.org "Ancestor ID" field prompting to autofill password after being signed in,

makay_murraymakay_murray
Community Member
edited January 23 in 1Password in the Browser

I recently got my grandfather set-up with 1password. He often uses FamilySearch.org genealogy work.

Everything works great except while inside familysearch.org in the person lookup section. the "person_ID" field prompts 1password to attempt to use that field as a 'password' field. This is both incorrect behaviour and disruptive behaviour. As the dialog covers up the "find" button for that field.

Can I get some assistance either:
A. disabling 1password for certain URLS? (https://www.familysearch.org/tree/find/id)
B. have this field recognized as NOT a password field.

image of problem:


1Password Version: 8.4.1
Extension Version: 2.2.1
OS Version: Windows 11
Referrer: forum-search:1password promting to login on domain after logging in

Comments

  • Joy_1PJoy_1P

    Team Member

    Hey @makay_murray, sorry to hear about the troubles your grandfather has experienced on FamilySearch.org. I created an account and took a look. I was able to replicate the behavior, and I can see why you've reached out. Just to check, what kind of input would go into that field? Would it be something new or different each time?

    Additionally, does your grandfather happen to use Safari on a Mac? We may be limited in what can be done, as the issue stems from how the website has coded the field. However, I'll be able to check on everything once I get your reply.

  • makay_murraymakay_murray
    Community Member

    Hi, joy!

    I hope you’re doing well!

    As for the field in question, it is almost always unique. It’s a persons unique 8 alphanumeric key for the database lookup. If you do this type of work you can tend to memorize keys and use this for quick lookup of people. But so far as 1password is concerned this field should not be saved.

    My grand dad uses edge on windows 11. Our family is “mixed” I have a mac but my grand dad does not.

    As an aside I read a few forum posts about a topic similar to this. It appears the feature “disable 1Password on specific URLs” has been asked for several times, but the support reps refused to acknowledged to pursue that feature… can I add a “+1” for that feature while we’re here?

  • Joy_1PJoy_1P

    Team Member
    edited January 25

    Thanks for the quick reply @makay_murray! Unfortunately, it looks like 1Password thinks that the field should be filled with a username (from my testing), and I have not been able to find an ideal workaround for it. I will report this to our developers so that they can look into the issue and so that in the end we can teach 1Password to not make suggestions via that field.

    At this time, there is not a way to disable 1Password for specific URL's, but it is indeed something that has been requested. I'll be happy to add your voice to the feature request, and I can also bring this up internally with my team. While I can't make any promises, I know this is something that would help many users, and I will do my best to advocate for it.

    For now, the best options would be to have your grandfather click on ESC to close the inline menu when he clicks into that field. He can also click on the blue 1Password icon to close the inline menu.

    One final option is to turn off the inline menu and keep it from automatically appearing in the browser. The thing to note though is that this would apply to all sites. If your grandfather doesn't mind, he can then click on the blue 1Password icon to bring up the inline menu so that he can save and fill his logins. I know this isn't an ideal solution, but it is something that could help with intrusive suggestions and yet would still allow your grandfather to utilize the inline menu when needed.

    To keep the inline menu from automatically appearing:

    1. Right-click the 1Password icon on the top right corner of the browser and select Settings.
    2. Go to Autofill and turn off the "Show autofill menu on field focus" option.

    I hope this can help for now. Let me know if you have any other questions!

    ref: dev/core/core#10331

    ref: dev/projects/customer-feature-requests#92

  • makay_murraymakay_murray
    Community Member

    Thank you,

    I’ll try the second work around you offered. That one seems like it would work pretty good until a more permanent software fix is applied.

    For now, you can consider this ticket closed. But I would love to hear back about this if that disable 1Password on some url feature is added or if this specific form field at family search is fixed

    Thanks again! Good night

  • Joy_1PJoy_1P

    Team Member

    @makay_murray You're welcome and thanks for your understanding. You can reach out anytime to us to check if there's been an update. Additionally, if there has indeed been an update, it would be published via our extension release notes, which can be found here: https://app-updates.agilebits.com/product_history/B5X Issue 92 would refer to the domain exclusion feature, and issue 10331 would refer to the specific form on the site.

    Thanks again for reaching out and for understanding. Let us know if there's anything else we can do to help.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file