Is PM SCIM Bridge 2.3.1 compatible with kubernetes 1.22?

Alex_ScobleAlex_Scoble
Community Member

Google has posted the following notice for upgrading GKE clusters to 1.22:
Starting with v1.22, Kubernetes has removed several v1beta1 APIs for more stable v1 APIs. Read more about this change. Please ensure that your cluster is not using any deprecated v1beta1 APIs prior to upgrading to GKE 1.22.

Does PM SCIM Bridge use any of those deprecated APIs or is it already compatible with kubernetes 1.22?


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided

Comments

  • DeVille_1PDeVille_1P

    Team Member

    Hi @Alex_Scoble. Thanks for reaching out. My name is De Ville and I'm from the provisioning team.

    I can confirm that the latest SCIM bridge (2.3.1) is fully compatible with GKE clusters 1.22 (and later).

    We went through the process of ensuring our configuration is compatible when Google announced the deprecation in Q3 2021.

  • Alex_ScobleAlex_Scoble
    Community Member

    Thanks very much!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file