Session was not authorized - Constantly

esttorheesttorhe
Community Member

OS: Ubuntu 20.04.4 LTS
WM: i3 (in case this helps)
op CLI version: 1.12.4
Polkit Configured/Enabled: yes
SSH_AUTH_SOCK: ~/.1password/agent.sock

~/.ssh/config

### default for all ##
Host *
  ForwardAgent no
  ForwardX11 no
  ForwardX11Trusted yes
  Port 22
  Protocol 2
  ServerAliveInterval 60
  ServerAliveCountMax 30

Host github.com
  IdentityFile ~/.ssh/id_github.pub
  IdentitiesOnly yes
  IdentityAgent ~/.1password/agent.sock

After many tried I managed to get to a point where it does seem to be working (at least running) but it doesn't matter what I try I keep getting the Session was not authorized

I thought at some point it might have been an issue with my key; so I generated a new one directly from 1P. I have tried specifying the IndentityFile as suggested in the docs to point to which key to use; still doesn't work.

When calling

ssh -vT [email protected]

I'm getting:

sign_and_send_pubkey: signing failed for ED25519 "<redacted>/.ssh/id_github.pub" from agent: agent refused operation
debug1: No more authentication methods to try.
[email protected]: Permission denied (publickey).

And from the logs:

INFO  2022-03-26T13:19:40.825 tokio-runtime-worker(ThreadId(3)) [1P:ssh/op-ssh-agent/src/lib.rs:370] Session was not authorized

This makes me think that the polkit is not working as expected; but I have already disabled/re-enabled and rebooted the machine multiple times.


1Password Version: 8.6.0
Extension Version: Not Provided
OS Version: Ubuntu 20.04.4 LTS

Comments

  • neobitneobit
    Community Member
    edited November 8

    Same problem with i3.
    My understanding is that 1password uses pop up to authorize (sic!) which is not shown.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file