1Password desktop is launching infinite browser tabs after enabling 2FA

roy_orbisonroy_orbison
Community Member

After unlocking the desktop client with my password, a 2FA dialogue pops up to authenticate with either OTP or Yubikey, it starts launching browser tabs that display the 1password.com sign in interface, with a message that my session has expired. These pages are unusable because another tab will launch after a couple of seconds and steal focus. Closing all the tabs did not prevent more from opening, only quitting the 1Password desktop client halted them. Reopening the client triggered the same issue but I was able to complete the 2FA and close all launched tabs.

It's usable but was an unpleasant intro to your 2FA system.


1Password Version: 8.6.1
Extension Version: 2.3.3
OS Version: Kubuntu 21.10
Referrer: forum-search:2FA

Comments

  • SavanniSavanni

    Team Member

    @roy_orbison Is this still happening to you? If so, could you send a message in to support, including a diagnostic report? I'd like to look at what's going on, because that is not behavior that I have seen before.

  • roy_orbisonroy_orbison
    Community Member

    I guess it was only a first run thing. I can't get it to repeat the bad behaviour after trying both requiring 2FA on next sign in and deauthorising for the desktop client. It was strange that it launched any link at all. Perhaps it was because it was trying to communicate with the browser add-on that wasn't 2FA authorised yet?

  • smgtsmgt
    Community Member

    I’ve also been having this problem. It’s happens when using 2fa and nowhere for 1p to save the code.

  • PeterG_1PPeterG_1P

    Team Member
    edited April 21

    Hi @smgt - thank you for letting us know you've encountered this. We're investigating the issue and will see what we can do about this from our end. I'll hope to have more for you soon!

    ref: dev/core/core#14622

  • crwrightcrwright
    Community Member

    I just encountered this same behaviour. I blamed it on my new Yubikey, which I was just testing out on a new (used) iMac. Catalina. 1Password 7 (up to date). Have not yet tried to reproduce it... but now the browser extension is refusing to load in chrome (where the infinite tabs had been opened). Will keep playing with it and report back.

  • PeterG_1PPeterG_1P

    Team Member

    Hi @crwright, sorry to learn that you have encountered this as well. We'll welcome any additional information you have to offer, and are investigating this internally as well.

  • wertwert
    Community Member
    edited May 20

    I am also having this issue after enabling 2FA in 1password on macOS Monterey (using 1password 8) and using the 1password Safari extension on two computers. The extension only behaves correctly on one computer at a time, and on the other it opens the infinite tabs asking for login. I will disable 2FA in the meantime and see if that addresses the issue for now.

  • PeterG_1PPeterG_1P

    Team Member
    edited May 28

    Hello @wert, I'm sorry to learn that you too have encountered this.

    Disabling 2FA should "work" as a workaround for the issue, and we've also found that turning off the integrate with 1Password app in your extension's settings menu, and then re-signing in with the account on the relevant profile/browser will stop the issue on that specific profile/browser.

    Of course, we're interested in implementing a fix on our end for this, and we're working on it. I hope that in the meantime this provides some remediation for the problem while we make that happen.

    ref: dev/core/core#14622

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file