Trouble with nationstarmtg.com Login

edited May 2013 in iOS

So over the weekend, in a password-changing, little snitch-installing frenzy, I changed my login password, but mistyped it. Twice. Consistently. I was able to recover from that by Apple helpfully letting me reset it after I gave my iCloud credentials. But the password for my login keychain refused to change back. Unable to guess how I mistyped the password originally, my only option was to delete the keychain and create a new one. Luckily, this was my media server, so it was of no consequence - except that the key for the encrypted second hard drive was lost. But luckily I had stored the key on drop box. So in the end I was able to fully recover but I really hate passwords.

I've made progress - I'm down to 129 separate logins but 33 still use a common password. All but 2 of those 34 are unimportant, tho.

Note: trying to log into https://www.nationstarmtg.com/MyAccount/Default.aspx via the 1browser (i.e., iOS) doesn't work. After putting in the credentials, clicking "sign in" does nothing. (Mmm, maybe that should go in the other forum.)

Comments

  • khadkhad Social Choreographer

    Team Member

    Note: trying to log into https://www.nationstarmtg.com/MyAccount/Default.aspx via the 1browser (i.e., iOS) doesn't work. After putting in the credentials, clicking "sign in" does nothing. (Mmm, maybe that should go in the other forum.)

    I just tested this in the 4.2 update to 1Password for iOS that was just released. I don't have an account there, so it's possible that there is still an issue. However, in my testing the username and password were definitely filled in correctly and appeared to be automatically submitted (since I have autosubmit enabled). The site told me the credentials were incorrect (which they were). This seems to me to indicate that it is working well.

    What version of 1Password are you using on your iOS device?

    What specific iOS device (iPhone 4S, iPad 2, etc.)?

    It sounds like everything is working well aside from the iOS filling issue you mentioned. Is that correct? I just want to make sure there is not anything else you need help with. :)

  • edited May 2013

    Mostly correct. Clicking on the URL causes it to properly open the page and fill in the credentials, but autosubmit doesn't occur (autosubmit is on...). Then I tap on "submit," the button changes color, but nothing happens.

    iPhone 5, iOS 6.1.4, iPassword 4.2. Copying and pasting the credentials into Safari has the same result - nothing happens. So I rebooted the iPhone. Still won't work, either in 1browser or Safari. So then I tried Chrome - nothing. I even tried "clear web data" and then 1browser again - didn't help. Then I tried Mercury - and with Mercury it worked fine. The Atomic browser also works fine.

    Then I took time to type all that above, and on a whim I thought I'd try logging in with bogus credentials (like you did). And it gave me the error you said. So then in Safari I tried my actual credentials and it worked. So then I tried it in 1browser and it worked.

    So then I logged out of the site, and tried logging back in and it's not working again.

    I tried bogus data again, and nothing happened. So in the end I can't discern any pattern to when it works and when it doesn't.

  • khadkhad Social Choreographer

    Team Member

    iPhone 5, iOS 6.1.4, iPassword 4.2. Copying and pasting the credentials into Safari has the same result - nothing happens. So I rebooted the iPhone. Still won't work, either in 1browser or Safari. So then I tried Chrome - nothing. I even tried "clear web data" and then 1browser again - didn't help. Then I tried Mercury - and with Mercury it worked fine. The Atomic browser also works fine.

    I'm not sure how that would be possible. We are all using the same WebView.

    Then I took time to type all that above, and on a whim I thought I'd try logging in with bogus credentials (like you did). And it gave me the error you said. So then in Safari I tried my actual credentials and it worked. So then I tried it in 1browser and it worked.

    Ah. Hm. Well, that sounds promising.

    So then I logged out of the site, and tried logging back in and it's not working again.

    I spoke too soon.

    I tried bogus data again, and nothing happened. So in the end I can't discern any pattern to when it works and when it doesn't.

    If you are seeing erratic behavior in all of those apps (including and especially Safari) it sounds like the problem is with the site not 1Password. I don't want to pass the buck if there is something we need to improve, but that is what it sounds like to me. After all that testing, would you agree?

  • khadkhad Social Choreographer

    Team Member

    I hope Nationstar Mortgage will be able to help you if you contact them about this puzzling issue. Please keep me posted if you find out anything more from them.

  • Yeah, uh, I'm not going to try to get a mortgage servicing company to take a look at heir web site. Doing that would make me lose my will to live.

  • khadkhad Social Choreographer

    Team Member

    Heh. You made me chuckle, and I understand the sentiment. But you don't know if you don't try. Maybe they would be happy to help. :)

  • Does this help at all?

    [WEB:0x1d55bd60:] @ webView:didFailLoadWithError: | Error Domain=NSURLErrorDomain Code=-999 "The operation couldn’t be completed. (NSURLErrorDomain error -999.)" UserInfo=0x20bbed30 {NSErrorFailingURLKey=https://www.nationstarmtg.com/MyAccount/Default.aspx, NSErrorFailingURLStringKey=https://www.nationstarmtg.com/MyAccount/Default.aspx}

  • khadkhad Social Choreographer

    Team Member

    If the issue is not limited to 1Password, I'm not sure there is that much that we can do. It could be an issue with WebView itself. But if you want to you can email us your complete diagnostics. Tap Settings > Advanced > Troubleshooting > Email Diagnostics in 1Password on your iOS device. Please be sure to include a link to this thread so we can "connect the dots" when we see your diagnostics in our inbox.

This discussion has been closed.