Can 1Password 7 and 1Password 8 live together in a Families Plan?

WardWard Junior Member
Community Member
edited May 19 in Families

All of the Macs and iOS devices in my Families Plan are using the latest release of 1Password 7.

If I take the lead by upgrading to 1Password 8 on my iMac running Monterey, will there be any problem sharing 1Password Vaults with others in the family?


1Password Version: 7.9.4
Extension Version: 7.9.4
OS Version: 12.3.1
Referrer: forum-search:1password 8 with 1password 7

Comments

  • BenBen AWS Team

    Team Member

    Hi @Ward!

    Can 1Password 7 and 1Password 8 live together in a Families Plan?

    Yep; not a problem.

    If I take the lead by upgrading to 1Password 8 on my iMac running Monterey, will there be any problem sharing 1Password Vaults with others in the family?

    Nope. 😃 With the launch of 1Password 8 for Mac, 1Password 7 for Mac is no longer supported and will only receive important security updates. Although folks can continue to use 1Password 7, it’s best to use the latest version of 1Password that includes all the latest features and security updates, so you should encourage your family to upgrade to 1Password 8 when you have the chance. But yeah, as of writing, there are no compatibility issues between the two.

    Ben

  • WardWard Junior Member
    Community Member

    Thanks, @Ben, for your speedy response.

    One of the family Macs is a 10-year-old MacBook Pro that still going strong, but it can't be upgraded past High Sierra. So it's stuck with 1Password 7.

    Those of us with trusty old Macs will greatly appreciate your maintaining 1Password 7 Vault compatibility as long as it's practical.

  • BenBen AWS Team

    Team Member

    One of the family Macs is a 10-year-old MacBook Pro that still going strong, but it can't be upgraded past High Sierra. So it's stuck with 1Password 7.

    Is there no option to upgrade to newer hardware, that is capable of running a modern operating system? 1Password 8 supports as far back as macOS 10.15, which is the oldest version of macOS that Apple is still providing security updates for. Connecting a system older than that to the internet is a significant risk. ☹️

    Ben

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file