Installation issue on AWS EKS. Unable to move pass the app setup page

ang2022ang2022
Community Member

Hi,

I am using the 1password/op-scim-helm helm chart to deploy the integration bridge.

The pod was generated to port 80, with service and ingress (AWS load balancer controller) on port 80, redirect the traffic to port 443 to port 8080 and enable the TLS encryption from AWS Certificate Manager.

80 -> 443
443-> 8080

However the integration page got stuck in the set up page which never prompted to enter the bearer token. After login 1Password Business (Admin) --> Intergration the base URL does not work

Appreciate if you have any advice regarding which ports should be enabled for Helm(kubernetes) version for TLS encryption and how to complete the setup and continue to set up in Okta? Thank you


1Password Version: Not Provided
Extension Version: 2.3.1
OS Version: Not Provided

Comments

  • laz.h_1Plaz.h_1P

    Team Member

    Hello @ang2022. I'm sorry to hear you are having this issue.

    Normally with the op-scim-helm configuration port 8443 is used for HTTPS. In order to further assist you if that doesn't work, I need some additional information about your certificate. Are you using your own certificate or Let's Encrypt?

  • ang2022ang2022
    Community Member

    Hello, I am using own certificate requested to the MSP on AWS. Would like to disable the usage for Let's encrypt. I tried to redirect 443 -> 8443 on a AWS Application Loadbalancer but 1password did not recognise the DNS. Thank you

  • laz.h_1Plaz.h_1P

    Team Member

    The setup server should not start on AWS, so the likely culprit of this issue is that your scimsession file is not properly installed as an AWS secret. If you haven't seen it yet, here are the instructions for settings up the scimsession file on AWS.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file