iOS syncing is unidirectional

FederalTotemFederalTotem
Community Member
in iOS

I use 1P on three devices: two Windows PCs and an iPhone. I have noticed that items are not being synced from the iPhone to either PC, but syncing in every other direction works flawlessly.

If I create a new item on either PC, it is immediately synced to the other PC and my phone. However, items created on my phone do not appear on either PC. This issue has been going on for a while before I realized what was happening, so I have a number of items on my phone that are "orphaned". I'm hoping there's a way to remedy this without having to manually copy items over from my phone, and I'd like to be able to create items on my phone going forward.

Any ideas what's going on here? I'm not able to find a similar thread, and I don't want to delete and re-sync, because it won't actually fix the problem.

I'm realizing I don't fully understand how items are being synced, given that neither WIndows machine is connected to iCloud...


1Password Version: 7.9.5 (iOS), 8.7.0 (WIndows)
Extension Version: Not Provided
OS Version: iOS 15.4.1, Windows 10 21H2

Comments

  • BenBen AWS Team

    Team Member

    Hi @FederalTotem,

    I'm sorry to hear about the trouble. On your iPhone, under 1Password > Settings > Vaults, do you see a vault called "Primary"? If so, please follow these instructions on that device:

    Migrate your existing 1Password data from standalone vaults to a 1Password account

    (including the bit at the bottom about removing the Primary vault once migration is complete)

    Please let me know what you find. 😃

    Ben

  • FederalTotemFederalTotem
    Community Member
    edited May 26

    @Ben, thanks for the response.

    I do see that I have a "Primary" vault on my iPhone. It seems that I need to manually migrate items between the Primary vault and the main vault of my 1Password account. However, this seems incredibly tedious, as there is no easy way to see which items need to be migrated. Any suggestions?

    EDIT: it seems like there are only 20 items in the Primary vault on my phone. I will manually move these to my 1P account and see if that brings things into parity.

  • FederalTotemFederalTotem
    Community Member

    Update: it seems that when I migrated my account, I somehow ended up not deleting the legacy Primary vault. Additionally, I think this vault was set as the default for new items on my phone, resulting in a gradual desynchronization between my phone and other devices.

    I manually migrated the items that had been created in the Primary vault after migration, and confirmed that the archived items in the Primary vault were in my 1P account vault. I then deleted the Primary vault so this problem doesn't happen again. It seems all is now well.

    @Ben, thanks for your help, much appreciated.

  • Dave_1PDave_1P

    Team Member

    @FederalTotem

    On behalf of Ben, I'm happy to hear that you were able to resolve the issue and that everything is working now. 😊

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file