Quick access crashes 1Password under Wayland

ariparip
Community Member

I have 1Password installed via .deb.
If I run this command:
1password --ozone-platform=wayland --enable-features=WaylandWindowDecorations --quick-access &
The first time I run it, and 1Password isn't running, it starts the main window and has me enter my password, and keeps 1Password running in the background. The second time I run it, it pops up the quick access window correctly. The third time I run it, it crashes the background running 1Password, and the following is output:

[513858:0601/110932.931220:ERROR:wayland_event_watcher.cc(292)] Fatal Wayland protocol error 0 on interface wl_surface (object 36). Shutting down..


1Password Version: 8.7.0
Extension Version: Not Provided
OS Version: Debian 11.3

Comments

  • PeterG_1PPeterG_1P

    Team Member

    Hi @arip, I'm sorry to learn of this issue. Thanks for letting us know it happened.

    I'll be happy to look into this for you. To start, I'll ask you to send us some diagnostics from your 1Password app, which can help us narrow down the specifics.

    How to Send Us Diagnostics from Your Linux Device

    First, try to replicate the issue as you've described it in your post. Then:

    1. Open the 1Password for Linux app on your device (the GUI).
    2. Press alt. A menu will appear at the top of the 1Password window. Click the 3-dot icon (...).
    3. Select File > Settings > Advanced > Send Diagnostics.
    4. Select Reveal to see the directory where the diagnostic file was generated.

    Then, attach that file to an email to us - you can reach us at [email protected] I'll let you know what we find and we'll do our best to expedite a solution for you.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file