1Password won't install. Thinks a newer version is installed.

shortbread31shortbread31
Community Member

I had 1Password on my computer. After a system restore the app completely failed to work. I tried to reinstall but it always refuses because it thinks it's still installed. I've since purged out 1Password from my Local and Roaming AppData, as well as the registry; however, I get the same error.

[2022-06-18 09:22:35.662328 +01:00] INFO [op_windows_starter::installer] op-windows-starter\src\installer.rs:587: Setup logs path set to : C:\Users\<redacted>\AppData\Local\1Password\logs\setup
[2022-06-18 09:22:35.662876 +01:00] INFO [op_log::private] foundation\op-log\src\private.rs:70: system locale detected as 'en-GB'
[2022-06-18 09:22:35.662903 +01:00] INFO [op_log::private] foundation\op-log\src\private.rs:70: selected translations for EN_US based on detected locale en-GB
[2022-06-18 09:22:37.282651 +01:00] ERROR [op_windows_starter::installer] op-windows-starter\src\installer.rs:488: A newer version of 1Password (80800137, newer than 80702002) is already installed. Aborting.
[2022-06-18 09:22:38.934728 +01:00] ERROR [op_windows_starter::installer] op-windows-starter\src\installer.rs:523: Failed to start app that is already installed. Error: The system cannot find the path specified. (os error 3)

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided

Comments

  • shortbread31shortbread31
    Community Member

    Figured it out... had to delete the uninstall key at

    HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall
    
  • ali.hazimeali.hazime

    Team Member

    Hey @shortbread31, thanks for the update. It's definitely strange that you continued to encounter that error after removing 1Password from your AppData folder. In any case, I'm glad to hear you were able to resolve this issue.

    Ali

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file