1Password browser integration doesn't work with Firefox Nightly [Fedora 36]

lolreppeatlollolreppeatlol
Community Member

Hi there!

I've noticed that 1Password's browser integration doesn't work with Firefox Nightly, at least when installed direct from Mozilla's website. I'm on Fedora 36 and it seems that the browser integration works fine with the pre-installed Firefox.

I know I could just use the pre-installed Firefox, but I'd rather avoid it if I could. Odd reasoning but I've been interested in the entire Firefox scene for a while and am moderately active in the community, and would much rather stay on the Nightly branch.

I've tried installing Nightly (putting the extracted folder) into both my personal Documents folder and the system /opt/ folder, but didn't notice that that helped with anything. I also moved the .desktop file back and forth from my personal account to the system applications folder, but no dice.

I know this is a pretty niche issue, but I figured it was worth a try to report this and see if that could help get this fixed. :)


1Password Version: 8.7.1
Extension Version: 2.3.5
OS Version: Fedora 36

Comments

  • mdanielmdaniel
    Community Member
    edited June 24

    Almost certainly sudo chown -R 0:0 $the_firefox_dir will fix it, and if not check the plugin log file as described here

  • PeterG_1PPeterG_1P

    Team Member
    edited June 29

    Hi @lolreppeatlol, thank you for highlighting this issue.

    Our developers worked on this and the issue is now resolved in the 2.3.7 Beta version of the 1Password browser extension. 🙌 If you're open to trying the Beta, I'd love to know if this solves the problem for you too!

    We've had a very high success rate so far, and believe that this should get you back up and running.

  • lolreppeatlollolreppeatlol
    Community Member

    Hey, unfortunately updating to the Beta version of the 1Password browser extension didn't work, but I tried mdaniel's solution and it worked. I really do appreciate the developers trying to fix this issue, though.

    Definitely let me know if there's anything I you'd like me to do to perhaps help the developers fix this issue in something like my previous configuration, though.

  • lolreppeatlollolreppeatlol
    Community Member
    edited July 3

    hey @mdaniel, while your solution worked for getting the 1password browser integration working, i find that my nightly updates don't work anymore. i think the updater doesn't really have permission to change the files in the nightly directory anymore, so definitely not an ideal solution.

    appreciate the help nonetheless though.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file