Can't use the new Alfred 5 workflow due to CLI issue

drpbierdrpbier
Community Member

Hi, I'm trying to run the CLI so that I can use the Alfred workflow with 1Password 8 for Mac. However it keeps telling me I'm using an old version despite installing the latest. The Alfred support admin asked me to run /usr/local/bin/op signin --force?
Terminal says:
iMac:~ davidbier$ /usr/local/bin/op signin --force
[ERROR] 2022/07/21 19:16:23 cannot create directory "/Users/davidbier/.config/op" and the parent directories: mkdir /Users/davidbier/.config/op: permission denied

The response was "You’ll have to ask 1Password about it. It’s their tool having the issue, which as you can attest happens even outside the Workflow. I did a quick search online and haven’t found anyone else affected with that exact problem."

This is over my head but I'm game...any idea?


1Password Version: 8.8.0
Extension Version: 2.3.7
OS Version: MacOS 12.4
Browser:_ Safari
Referrer: forum-search:Can't use the new Alfred 5 workflow due to CLI issue

Comments

  • drpbierdrpbier
    Community Member

    Probably helpful to post this too:

    The issue is that the 1Password command-line tool, op, is unable to create the configuration directory:

    cannot create directory "/Users/davidbier/.config/op" and the parent directories: mkdir /Users/davidbier/.config/op: permission denied

  • Dayton_agDayton_ag

    Team Member

    Hey @drpbier, I'm sorry you're running into issues! Let's see if we can get you up and running.

    First, you mentioned that your terminal keeps telling you that you're running an older version of the CLI. Could you run the command op --version and let me know what version it says you're running? If you're running CLI 1, could you run through the steps found at the link below to upgrade to CLI 2, and let me know if you're still seeing this issue:

    Upgrade to 1Password CLI 2 Developer Documentation

    Let me know how it goes and we can keep the ball rolling from there. Thanks! 😊

  • drpbierdrpbier
    Community Member

    It says 2.5.1

  • Horia.Culea_1PHoria.Culea_1P

    Team Member

    Hey @drpbier,

    Thanks for reaching out to us. From what I understand from your original post, you want to use the 1Password CLI with the 1Password 8 app (i.e. the biometric unlock integration), is this correct?

    To start debugging this, let us know, is the first error that you're getting, the one related to "using an old version despite installing the latest", triggered by installing the CLI, or the 1Password application?

    The other error, i.e. the output of /usr/local/bin/op signin --force is not an error you would usually see with biometric authentication enabled. It is an error from the manual authentication workflow, so this is hinting me to think that the CLI integration may not be enabled in the 1Password application.

    So, please, let us know more about your use-case, to make sure we can provide the proper assistance.

    Looking forward to hearing back from you!

    Best,
    Horia

  • drpbierdrpbier
    Community Member

    Hi - no, I just want to use Alfred to search 1P v8 for logins and open them in my browser as I used to do with 1P v7. Apparently 1P v8 does not support the previous kind of integration that 1p v7 did and this now requires the CLI to support an Alfred workflow, which keeps throwing the above error which is apparently due to being "unable to create the configuration directory"

  • drpbierdrpbier
    Community Member

    Any ideas?

  • ag_tommyag_tommy

    Team Member

    @drpbier

    My apologies, that we have not gotten back to you. Let's get you on the latest version and see if that helps.

    I can confirm that version 2.6 is the latest and you are a version behind. The newer version was released on July 21st. Which is incidentally the day you started this conversation. I am not sure where that played in as far as the error. I don't think the update should have posed an error. Can you run op update or alternatively you can download the latest here and run the installer.

    1Password CLI Release Notes - v2060007

  • drpbierdrpbier
    Community Member

    OK - tried updating:

    iMac:~ davidbier$ op update
    [ERROR] 2022/07/26 13:51:51 cannot create directory "/Users/davidbier/.config/op" and the parent directories: mkdir /Users/davidbier/.config/op: permission denied

  • ag_tommyag_tommy

    Team Member

    @drpbier

    Thanks for trying that. Can I ask you to email us? It sounds as if we may need to gather logs and a direct line of communication would surely help with that. Plus it's something we cannot do here in the community, for your privacy. The community is an open medium.

    Please use [email protected] for your submission.

    • Your forum username: drpbier
    • A link to this thread: https://1password.community/discussion/131657/cant-use-the-new-alfred-5-workflow-due-to-cli-issue#latest
  • jraddinjraddin
    Community Member
    edited July 28

    I had this exact same issue. Ended up being because the .config directory in my home folder was owned by root rather than me.

    Confirm by running ls -la ~ | grep .config

    Mine was:
    drwxr-xr-x 4 root staff 128 Jul 27 22:54 .config

    This means that directory is owned by root and grouped to staff

    To resolve:
    sudo chown username ~/.config where "username" is your actual username. You can find that by running the command whoami

  • drpbierdrpbier
    Community Member

    Thanks @jraddin - perfect!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file