1Password breaks Firefox textbox auto complete

Daniel1Daniel1
Community Member
edited August 9 in 1Password in the Browser

When I set the focus to a textbox where both, the Browser provides auto complete values, and 1Password recognises it as a login form, then I'm unable to press the arrow-down button to select cached auto complete values. This should not happen. When the 1Password suggestion is incorrect, I should be able to select a different value as I am used to, with the arrow-keys.

For example, here I open a website and 1P suggests to enter a value [email protected]

It's not the email address I want to use, so I start typing and the browsers auto complete feature starts recommending values.

I usually then press arrow-down on my keyboard to select one of the browser's auto complete suggestions. But then the 1P extension overrides this, removes the auto complete suggestions and forces the focus on itself.

This is a big nuisance and does happen quite often. When I see that the 1P suggestions are incorrect (image 1), and I start typing and the browser's auto complete features kicks in (image 2), then I have already decided that I want to use the auto complete feature. In cases where there is already input in a textbox AND the browser's auto complete shows suggestions, THEN 1Password should NOT force itself to the foreground when pressing arrow-down and let the browser do its thing.


1Password Version: 8.8.0
Extension Version: 2.3.7
OS Version: Windows 10
Browser:_ Firefox 103.0

Comments

  • Daniel1Daniel1
    Community Member

    I posted to the wrong forum. I'm not using the beta's. Sorry :S

  • Jack.P_1PJack.P_1P

    Team Member

    Hi @Daniel1:

    While generally we'd recommend disabling your browser's built in autofill to avoid conflicts like this, it's definitely possible to use them together. Right click the 1Password icon in Firefox's toolbar, then choose Settings. Disable the setting "Show autofill menu on field focus".

    This will prevent 1Password from displaying on the fields when they're focused, and instead will only show when you click the 1Password icon in the field. Let me know how you get on with that!

    Jack

  • Daniel1Daniel1
    Community Member
    edited August 11

    Hi @Jack.P_1P, I can live with that workaround, thank you.

    However, I believe the UX would be much better if the autofill menu would disappear once you start typing in the input. When you start typing, you probably already determined that 1P does not have any relevant entries for a particular textbox. That way, you can still have the "autofill menu on field focus" enabled, but not in the use-case where you don't want it obstructing your actions.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file