Browser and desktop app sync not working.

bravedistributionbravedistribution
Community Member

Hi,

I have a DELL XPS 13 laptop, ubuntu 22.04 kernel 5.15.0-46-generic - I use KDE as a DE with i3 as window manager.

Syncing between the app and browser(s) doesn't work. I downloaded deb file from the page:
1password-latest.deb
ii 1password 8.8.0 amd64

I installed 2 browsers:
1/ firefox from apt repo
2/ brave from snap

not a single browser works. I have checked the "Integrate with the desktop app" in the extension settings and also the option in "Connect with 1password in the browser" in the app.

Browser extension version: 2.3.7.

thanks for the quick response.


1Password Version: 8.8.-0
Extension Version: 2.3.7
OS Version: Linux
Browser:_ Firefox, Brave

Comments

  • ForstForst
    Community Member
    edited August 15

    I see you mention Firefox is from apt specifically on your system, but I'd like to highlight that on Ubuntu 22.04 Firefox has been switched to Snap by default.

    As of today, the support for Native Messaging in Firefox Snap is still in beta. I've installed the beta with snap refresh firefox --beta, but the browser integration still doesn't work. Wonder if it's related to what you're experiencing with apt-based Firefox install.

    Related Ubuntu Discourse topic: https://discourse.ubuntu.com/t/call-for-testing-native-messaging-support-in-the-firefox-snap/29759

  • bravedistributionbravedistribution
    Community Member

    Thanks for the answer! I tried that out on Brave as well, so this isn't browser-specific.

  • bravedistributionbravedistribution
    Community Member

    I went through that post, however, I don't have any webextensions listed in flatpak... 1password seems to be a bit different to the password manager they use.

  • bravedistributionbravedistribution
    Community Member
    edited August 19

    Interesting. 7 days without a reply on rather a big bug. I am sorry that I bought this subscription.

  • AliH1PAliH1P

    Team Member

    Hey @bravedistribution, I apologize for our delayed response.

    If your browser has been installed from Flatpak or Snap, it's sandboxed from other processes meaning that the communication between the 1Password browser extension and the main app can't take place. To allow the browser extension to lock and unlock along with the main 1Password app, you'll need to install a browser from a source like deb or rpm, depending on your distribution.

    Regarding Native Messaging support in Firefox Snap, this is definitely something our team has been waiting for. Although I don't have any timelines to share, this is on our radar and hopefully this distribution now includes what we need to allow the main app and browser extension to communicate.

    Brave have instructions on how to install through deb here: Installing Brave on Linux | Brave Browser

    Before completing those steps, you'll need to run flatpak remove brave or similar.

    Similarly, Firefox has been switched to Snap by default. So using the apt command installs the Snap version. You can find steps to install Firefox from a deb package here: How to Install Firefox as Classic DEB App on Ubuntu 22.04

    Let me know if that resolves the issue for you!

    Ali

  • bravedistributionbravedistribution
    Community Member
    edited August 25

    Hi Ali,

    It does not work neither on Firefox and brave from deb package. Do your tests cover this scenario or you just hope that it might work on Linux? If there's no support for that, you should probably disable the feature completely so people don't have high hopes.

  • AliH1PAliH1P

    Team Member

    Hey @bravedistribution, thanks for your reply. I'm sorry to hear the provided steps didn't help in your case. Browser integration should definitely work with the deb packages. To investigate further, I'd like to ask you to send us some diagnostic logs:

    Attach the both to an email message addressed to [email protected].

    With your email please include:

    We'll look forward to hearing from you.

    Ali

  • korn94samkorn94sam
    Community Member

    I was able to get around this issue, maybe this can help others. I am running Ubuntu 22.04, and ran into the issue of installing from snap.

    NOTE: You MUST install your browser AND 1Password from deb and not from snap.

    Double check this with sudo snap list and make sure your programs aren't listed there. I was unable to get Firefox to install not as a snap, even following the above link, still installed the Firefox as a snap. I also looked into UbuntuZilla, but that gave me lots of headaches too...

    In the end I installed Brave, which had nicer instructions that worked with all the quirky "deprecated apt-keyring" of Ubuntu 22.04.
    https://brave.com/linux/

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file