1Password on Mastodon

On web browsers, have to click on the toolbar every time to unlock 1Password

jeongh0117jeongh0117
Community Member

Before, I was able to unlock 1Password on the browser by clicking on the ID/PW field popup. So when I click on the ID/PW field, the 1Password extension showed me the accounts related to the website, and I was able to simply unlock right away by using touch ID.

However, when I try to do the same thing now, I keep get prompted to click on the toolbar 1Password icon to unlock.

So is there a way to unlock the web browser 1Password like before, or else is there a way to keep the browser 1Password unlocked every time?


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Browser:_ Not Provided
Referrer: forum-search:toolbar password

Comments

  • jason_kjason_k
    Community Member

    I find myself frequently having this same issue, and I have a hard time believing this is the intended workflow. I think I figured out what's happening, though.

    After upgrading to 1Password 8, I often find that hitting ⌘-\ to autofill does ... nothing. Sometimes it works, but many times it doesn't, which is obviously frustrating. I expect to be prompted to unlock, place my finger on the TouchID sensor, and then watch the fields get autofilled. (Needless to say, this worked flawlessly with 1Password 7 every time.)

    This always catches me off-guard, so then I move my cursor to click on the tiny 1Password icon. Then I'm reminded that I need to "press the 1Password icon in your browser's toolbar to unlock." (But why?) So then I move my cursor again and click the other icon.

    This launches 1Password, which immediately quits itself — which is weird, but okay — and then after a moment I can use TouchID to proceed. Obviously this is not a very slick experience.

    What I've noticed is that while I have 1Password open, this all works as expected. Hitting ⌘-\ will instantly prompt me to unlock with TouchID and then autofill. If I close 1Password using the close button on the window, this sometimes stops working ... but not always. If I quit 1Password with ⌘-Q, it never seems to work anymore. I know in the past there were some options like "Quit 1Password Completely", but I can't seem to find those anymore, and if this new behavior is intentional, it's extremely confusing.

    As it happens, I'm frequently opening the 1Password 8 app (using a keyboard launcher similar to spotlight) and closing it using the keyboard (⌘-Q) due to limitations and problems with the new universal search and browser popup. So I guess that's what's triggering the issue for me, but I'm still very confused about what's expected and what's buggy behavior.

    Thanks in advance for any help with this issue.

  • Hi @jason_k:

    By any chance do you have "Keep in menu bar" disabled in Preferences > General for 1Password? If that's disabled, then using ⌘+Q to quit 1Password will result in 1Password quitting completely and not being able to respond to keyboard shortcuts.

    @jeongh0117:

    It sounds like 1Password for Mac might be having trouble communicating with 1Password in your browser. Does a restart of both 1Password and your browser improve your state of play? Let me know.

    Jack

  • jason_kjason_k
    Community Member

    @Jack.P_1P — aha, that seems to explain the issue for me! It really wasn't clear to me that this preference was linked to this behavior.

    I'm glad to have it sorted out now, but I think it would be nice to update the detail text below the preference to mention this other side effect. Or, perhaps ideally, change the behavior so that hiding the menu bar item doesn't affect 1Password's ability to respond globally to keyboard shortcuts! Either way, thanks.

  • vlaeservlaeser
    Community Member
    edited January 25

    Hi,

    Since I upgraded to version 8, i have the same problem as @jason_k with the pop up in the user field asking me "press the 1Password icon in your browser's toolbar to unlock", which is very, very frustrating.

    After a lot of testing, research, bootings and reinstallations, it seems to be related to what is mentioned above. Hiding the menu bar icon completely kills 1password and makes the user experience bad in firefox. With that damn popup. So reactivating this option works for me (finaly!) But I don't want to keep this icon in the menu bar. it takes up space, it's ugly and it's useless to me!

    Please fix this it's a bit annoying.

    Thanks

    MacBook Pro M1 / Mac Os 12.6 / Firefox 109.0 / 1Password for Mac 8.9.13 (80913040) / 1Password extention 2.5.1

  • EvonG1PEvonG1P

    Team Member
    edited January 25

    Hello @jason_k, @vlaeser I'm glad that the issue is now fixed. I can't make any promises but we are tracking feedback to improve this in the future and I've added you both.

    Thank you for the feedback!

    ref: dev/core/core#9557

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file