Secure Desktop not Working

I have the Windows Beta edition, (or I think I have). Opening on a secure desktop worked most of the time even if not always.Now, since two days ago, it doesn't work at all on my PC. Any thoughts??


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Browser:_ Not Provided

Comments

  • GreyM1PGreyM1P

    Team Member

    Hi @Andrew42

    Could you confirm which version of 1Password you're using? Here's what to find out:

    1. Open and unlock 1Password.
    2. Click the menu > Settings...
    3. On the About tab, look for the version number. The 8-digit number starting with 8 is the most useful one as it tells us the exact build.

    I look forward to hearing from you so we can help you out. :)

    — Grey

  • Andrew42Andrew42
    Community Member
    edited September 20

    Thank you @GreyM1P. My version # is 80906011 on the Beta channel. Opening on a secure desktop is back even though it is extremely temperamental. I wrote my comment 12 days ago. It seems to me that 1P probably issued a new definitive version to which we were all automatically updated. This definitve version did not have Secure Desktop. Now I'm back to a Beta version, the Secure Desktop is back and works properly about every third time. It is sad that such a basic security feature was not included both when 1P8 was launched and even now, months later.

  • 1P_Gem1P_Gem

    Team Member

    Hi @Andrew42, thanks for getting back to us! We released a Production update on September 7th, which would line up with your initial post. I'm glad to hear that you're now on Beta 8.9.6-11 and Secure Desktop is available again. Could you provide any details about what happens when Secure Desktop isn't working properly?

  • Andrew42Andrew42
    Community Member
    edited September 22

    Black screen. I get over this by going to Task Manager and cancelling the two 1Password listings in Background Processes. On Exit I am returned my Home screen where the short cut to invoke 1P no longer works but I can log in via the app or the browser extension secure desktop doesn't even bring me a black screen. just nothing. To try and get into Secure Desktop I have to reboot entirely.

    By the way I have updated manually to 8.9.6. I have checked to be updated automatically but that clearly is also not working, for me at least.

  • 1P_Gem1P_Gem

    Team Member

    Hi @Andrew42! Thanks for the additional details about the trouble you're running into with Secure Desktop. This sounds like a known issue we're looking into at the moment, and I've added you to the list of impacted customers.

    ref: dev/core/core#11570

    I'm sorry to hear that you had to manually update to 8.9.6 even though you've checked the option to install updates automatically. If you open the app and take a look under ⋮ > Settings > Advanced, is the dropdown menu for release channel set to Beta?

  • Andrew42Andrew42
    Community Member

    Yes my Settings are for Beta. It is no big deal. I'll watch it for a few weeks and see if it occurs again.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file