"Hide on this page" does not work

I use 1Password and work as a software developer primarily on web applications. I prefer to disable 1Password when working on something because of the code injected into forms (and the "network" requests that are made to load assets from the extension bundle).

The "Hide on this page" functionality does not work consistently at all. If I right click a text field and select the option it will disable the 1Password extension on that page...for a period of time. It always comes back after a few refreshes or some period of time elapses. I haven't been able to figure out a pattern exactly other than it comes back.

When this happens, I can right click a text field and see that the "Hide on this page" option is still checked - even though the 1Password extension is visible on the form field (see screenshot):

  1. Can the "Hide on this page" functionality be fixed so that it works consistently?
  2. How long is the "hide on this page" setting supposed to last? Can it be made to last permanently?
  3. Can an option be added to disable 1Password on specific domains? Or even just on localhost? Or on non-HTTP sites? Any of these options would work for me and I'm sure many others. Unfortunately, Chrome only lets me set an "allow" list on the extension so I cannot blacklist 1Password for any one domain.

1Password Version: 8.9.5
Extension Version: 2.4.4
OS Version: Windows 10 Pro 21H1 19043.1889
Browser:_ Chrome 105 and Brave 1.43.89

Comments

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file