Improved automatic selection of icons for software licenses?

mstamatmstamat
Community Member
edited September 11 in Windows

Hello.
Today I started using 1Password for storing the software licences I manage in one place. I was excited to see the generic icon changing to a Windows 11 icon when I typed "Windows 11" in the entry name:

But then came dissapointment, because the icon changes only when the name of the entry is exactly "Windows 11". I would expect a fuzzier match for choosing the right icon. E.g. all of the following should automatically pick the Windows 11 icon.

Moreover, it would be great if in addition to "Choose a new icon" which lets me pick an icon from my files, there was a second option that allows me to browse the icons bundled with 1Password.

Can I hope for these improvements?


1Password Version: 8.9.5
Extension Version: Not Provided
OS Version: Windows 10
Browser:_ Not Provided
Referrer: forum-search:icon license

Comments

  • Jack.P_1PJack.P_1P

    Team Member

    Hey @mstamat:

    Thanks for your feedback on this! I can definitely see how the matching could be improved here, as well as the ability to manually search for an icon. While I can't promise anything, I've shared your thoughts with the team!

    Jack

    ref: IDEA-I-1854

    ref: IDEA-I-1855

  • mstamatmstamat
    Community Member

    Thanks for forwarding my feedback to the team @Jack.P_1P ! Hope we have the improvements in a near-future update :)

  • ag_mike_dag_mike_d

    Team Member

    On behalf of Jack, you're most welcome! 👍

  • DenalBDenalB
    Community Member

    Hey @mstamat !

    That's why I changed all my icons manually by myself. Also, I do this when creating a new entry, no matter what entry this is. It is a bit of work, but you only have to do this once. I have a folder on my drive where all the icons are stored. So when creating a new entry and need the same icon I already used, I'm able to select it.

    Here's how my software license entries look like.

  • Andrew42Andrew42
    Community Member
    edited September 22

    @DenalB. What an excellent idea. I have Just found a piece of free software that lets me extract *.ico files from *.exe files. where I don't have an *ico file listed. What I like about the software is it also lets me save the file as *.ico and not *.bmp or *.jpg

    @1P: Two things I have found as I manually changed some icons in 1P on my Windows PC

    Firstly, when I changed the icon and saved the record the icon changed for the record but not in the list of Software on the left hand side. For that to change I had to back out of 1P and come back in again. Thinking about it, maybe I didn't have to back out of 1P but just changing the category from Software to Favourites and back again would have had the same effect. No that didn't work. I've just changed another icon and had to back out to get the List of software to update.

    Secondly. Sometimes when I saved the record I got an error message saying something like "The Software can't be saved" and something about encryption. I'm sorry I did not catch the complete error message. Anyway the error message was an error in itself because the record did save although the new icon did not show until I selected another record and than went back to the first one. In that case too the left side list did not change as in point 1.

    Reading what I've written makes me feel I've been a bit muddled in my explanation. Feel free to tell me if it's not clear.

  • ag_mike_dag_mike_d

    Team Member

    Hello @Andrew42,

    I'm sorry to hear of the issues you've been encountering with the icon updates for Software License items.

    To confirm your first point, it sounds like the icon for the Software License item in the item list (center pane) it not updating immediately after saving the item and until you've exited and signed back into 1Password. This is behaviour I'm not seeing after creating several different software license items in a row. Could you let us know if you are also seeing this when manually changing the icon on any item?

    I'm not sure that I recall ever witnessing the "The Software can't be saved" error message that you spoke of and would like to ask if you could send a couple pieces of information to us at [email protected] after attempting reproducing these two behaviours? Do not post these details in the forums.
    1. Can you send a 1Password diagnostics report via email to [email protected] so we can help to investigate?
    2. A screenshot of the "The Software can't be saved" error message you are receiving. When sending a screenshot, be sure to redact any personal or private information.

    If you could also include a link to this thread and your forum handle, this will help us to "connect the dots" when we see your report in our inbox. Thanks!

  • Andrew42Andrew42
    Community Member

    @ag_mike_d . Thanks. I’ll get back to you on this, probably tomorrow. I need to try and re-create the error message. All my changes were manual.

  • Andrew42Andrew42
    Community Member

    @ag_mike_d. Here we go:
    Yes, I am seeing the same issue when I change an icon in Logins, for example. I tested this after you question,

    Attached is the error message (22-09-23.jpg)

    The next three screenshots are the sequence of what happens when I change an icon. These may seem to be in the wrong order, but they are not.

    Here I have chosen the new icon but not yet saved the record.

    Here I have saved the record and, yes, the new icon has disappeared. This does not always happen but it not appearing on the left side list always happens.

    . Here is the result after the previous two and when I have backed out of 1P and come back in.

    I have tested and if I copy the url of the screenshot I can see it correctly on my computer. If you cannot see them I can attach them to an email if you tell me how to phrase the subject matter so it can be linked to this.

    I will run the diagnostics report and send it later.

  • Andrew42Andrew42
    Community Member

    I tried to send the diagnostics report. Here is the error message I received:

    "The following recipient(s) cannot be reached:

      '[email protected]' on 23/09/2022 13:01
            This message could not be sent. You do not have the permission to send the message on behalf of the specified user. "
    

    I am trying to work out what the problem might be. Can you help; I am sending from a my gmail account with 1P as a plus in the sender name.

    I have tried a second time and the error message says there is a problem with reception and I should try again later: I will..

  • ag_mike_dag_mike_d

    Team Member

    Good morning @Andrew42,

    Thanks for your message and sending along the previous screenshots. This appears to be an issue with a delay in syncing the data. Once we receive the diagnostics report we can investigate further.

    To confirm, the correct email address to send the diagnostics report to is [email protected]. Thanks and looking forward to your response.

  • DenalBDenalB
    Community Member

    Hey @andrew42!

    The following recipient(s) cannot be reached

    There is an error in the email address! It is not [email protected]. The domain should be 1Password. 😉

  • Andrew42Andrew42
    Community Member

    Right. Stupid of me. Thank you.

  • DenalBDenalB
    Community Member

    You're welcome. 👍

  • Andrew42Andrew42
    Community Member

    I've managed to send the diagnostics report and I have worked out what is happening but not why nor how to cure it. It has nothing to do with 1P. I have a gmail account with several Plus addresses. One is for 1P. My email address for 1P is [email protected] Anything I send from that sender address fails whether it is to 1P or to one of my other accounts. So I sent my diagnostics from my main gmail account and it went through without a problem. I have no idea how to cure this and would be extremely grateful for any help.

  • ag_mike_dag_mike_d

    Team Member

    Thanks for letting us know you've sent along the diagnostics report, @Andrew42. We'll be in touch shortly.

    ref: RWI-43785-914

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file