"Hide on this page" does not work

I use 1Password and work as a software developer primarily on web applications. I prefer to disable 1Password when working on something because of the code injected into forms (and the "network" requests that are made to load assets from the extension bundle).

The "Hide on this page" functionality does not work consistently at all. If I right click a text field and select the option it will disable the 1Password extension on that page...for a period of time. It always comes back after a few refreshes or some period of time elapses. I haven't been able to figure out a pattern exactly other than it comes back.

When this happens, I can right click a text field and see that the "Hide on this page" option is still checked - even though the 1Password extension is visible on the form field (see screenshot):

  1. Can the "Hide on this page" functionality be fixed so that it works consistently?
  2. How long is the "hide on this page" setting supposed to last? Can it be made to last permanently?
  3. Can an option be added to disable 1Password on specific domains? Or even just on localhost? Or on non-HTTP sites? Any of these options would work for me and I'm sure many others. Unfortunately, Chrome only lets me set an "allow" list on the extension so I cannot blacklist 1Password for any one domain.

Noted this before: https://1password.community/discussion/116572/disable-for-certain-urls#latest (November 2020) and still does not seem to be fixed almost two years later.


1Password Version: 8.9.5
Extension Version: 2.4.4
OS Version: Windows 10 Pro 21H1 19043.1889
Browser:_ Chrome 105 and Brave 1.43.89

Comments

  • rage8885rage8885
    Community Member

    Hoping for an update or response on this, as it's been an ongoing issue for quite some time.

  • rage8885rage8885
    Community Member

    Hoping for an update or response on this, as it's been an ongoing issue for quite some time.

  • rage8885rage8885
    Community Member

    Hoping for an update or response on this, as it's been an ongoing issue for quite some time.

  • rage8885rage8885
    Community Member

    Hoping for an update or response on this, as it's been an ongoing issue for quite some time.

  • DenalBDenalB
    Community Member

    It's a known issue, @rage8885 ! "Hide on this page" only works temporary as long as you let the browser / site open.

    Hopefully this will be fixed or added soon.

  • rage8885rage8885
    Community Member

    At this point, it doesn't even work if you leave the browser / site / tab open - after a period of time it will stop working. To get it working again you need to uncheck the option and then recheck it.

    Two years for what should be a fairly minor fix without a response from the developers besides (we'll look in to it) is frustrating. But at the end of the day, all I can do is sit and bump this post once a week and hope someone pays attention.

    I'm not going to sit and make empty threats of "finding a better product" or that I'm going to take my money elsewhere. Honestly, I love 1Password and besides this literal single complaint I don't have any problems with it - it does what I need, it's cross platform and it runs nice and stable without problems. I would just appreciate some kind of feedback from the team after two years.

  • DenalBDenalB
    Community Member

    Hey @rage8885 !

    I also love 1Password. But actually I have the feeling that 1Password team is a bit busy answering every discussion here and also via e-mail. There are some critical issues where no one from 1Password is answering. Strange ... 🤔

  • rage8885rage8885
    Community Member

    Hoping for an update or response on this, as it's been an ongoing issue for quite some time.

  • DenalBDenalB
    Community Member

    I also hope for an update here ... 😢

  • rage8885rage8885
    Community Member

    Hoping for an update or response on this, as it's been an ongoing issue for quite some time.

  • Joy_1PJoy_1P

    Team Member
    edited November 24

    Hey @rage8885, we have been a bit busy, but that isn't an excuse. I'm very sorry for the delay in getting back to you.

    Can an option be added to disable 1Password on specific domains? Or even just on localhost? Or on non-HTTP sites? Any of these options would work for me and I'm sure many others. Unfortunately, Chrome only lets me set an "allow" list on the extension so I cannot blacklist 1Password for any one domain.

    This feature does not yet exist. However, we do know that it is a popular request, and we have brought it up to our developers. We will continue to let them know about any and all feedback that we get. We will won't stop advocating for it on your behalf.

    As for the "hide on this page" option, I tested it out and it works pretty consistently for me. That said, I only tested via Safari as it's the only browser that I'm able to fully close at the moment to disable "hide on this page". The only other way to disable "hide on this page" is to open the menu and de-select it. The "hide on this page" option should not be disabled if you refresh the page.

    Although I have not been able to reproduce the inconsistency that you mentioned, I do want to learn more about your environment and the steps you took. Could you let me know what browser you're seeing this with? Does it happen on a specific website? What is the website from the screenshot that you shared? How long do you keep your browser open before you see 1Password's suggestion come back?

    Please let us know about the above and we will look into things further!

    IDEA-I-293

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file