1Password extension for Safari not working after update

After Safari updated to 16.0 my 1password extension went away. I have 1Password for Safari installed (I tried removing and reinstalling it as well) and when I open it I'm prompted to open Safari preferences. When I click the blue button nothing happens. When I manually open Safari preferences and look under extensions it was no extensions. Not sure what else to try. I did quite everything and restart as well, still same issue. Thanks for the help..


1Password Version: 8.9.4
Extension Version: 2.3.7
OS Version: 12.6
Browser:_ Safari
Referrer: forum-search:Safari extension not working

Comments

  • iwaddoiwaddo
    Community Member
    edited September 22

    I upgraded last week so my issue iOS not directly related to the upgrade but of course my Mac may have applied system data files and security updates overnight. Is there a way to tell?

    All was well yesterday, this morning the extension has just disappeared, no sign of it whatsoever.

    This terminal command has restored normal service (after quitting 1Password and opening it again)

    /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -f -R /Applications/Safari.app

    Very odd........

  • ag_tommyag_tommy

    Team Member
    edited September 22

    @orin

    Open 1Password and from the menu bar at the top of the screen select Help > Troubleshooting > Fix missing Safari extension.

    @iwaddo

    If you would rather trigger this from the built in function. Either should do the job. 🙂

  • orinorin
    Community Member

    @ag_tommy That fixed it, thanks!

  • ag_tommyag_tommy

    Team Member

    That's great to hear. Enjoy!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file