quick access shortcut only works from main window of application on Ubunutu 22.04

Community Member

The quick access keyboard shortcut only works when the main 1Password application window is open and focused. When main window is unfocused or not open (but 1password is still running in tray), the keyboard shortcut has no effect. Clicking tray icon > Open Quick Access also works fine, just not the shortcut (Ctrl+Shift+Space).

1Password Version: 8.9.4
Extension Version: 2.3.8
OS Version: Ubuntu 22.04
Browser:_ Chrome
Referrer: forum-search:quick access shortcut only works from main window of application


  • AliH1P
    edited October 2022

    Hey @ekallevig, thanks for reaching out and bringing this to our attention. I've just tested this and encountered the same behaviour. I've gone ahead and filed an internal issue for our developers to investigate further. Thanks again!


    ref: dev/core/core#18003

  • ekallevig
    Community Member

    I noticed the shortcut seems to sometimes start working after the app has been running a while fwiw. But right after opening the app the shortcut seems to reliably fail (when the main window is either closed or unfocused).

  • Hello again @ekallevig - apologies for the delay. I've passed these additional details along to the team. Thanks for the update.

  • tbalthazar
    Community Member


    I just wanted to report that I experience the same issue under Debian testing (bookworm) under Gnome.
    I have 1Password for Linux 8.9.13 (80913040).


  • Hi @tbalthazar! Thanks for letting us know about this - I've added these details to the issue on file 😄

    ref: dev/core/core#18003

  • dschwignel
    Community Member

    Hello. I've been using the 1password for linux for a long time and It worked until they switched to wayland for default. When I switched back to using xorg, my quick access started working again from any windows. This might help looking for the problem.

    You can check if Ubuntu is on wayland using the following script:

    If "wayland" is prompted, try loggin out and switching to xorg on the initial Ubuntu screen (It will say just "Ubuntu" instead of "Ubuntu on Wayland")

  • Thanks for sharing your solution @dschwignel - it's greatly appreciated 😃


  • lumarel
    Community Member
    edited May 2023

    Hi everyone,
    I took a bit of a look around if this can be worked around somehow.
    Apparently this is a security feature of wayland to not allow global keyboard shortcuts because it's the same as keyboard sniffing.
    Didn't find the issue/thread up to now where they are looking for a solution to that problem, but at least there are workarounds for GNOME and KDE,
    GNOME, by setting a shortcut in the GNOME settings:

    KDE, by adding a action identifier to the .desktop file, and then configuring the shortcut afterwards in KDEs settings:

    [Desktop Action QuickAccess]
    Name=1Password Quick Access
    Exec=1password --quick-access

    Cheers lumarel!


  • Hi @lumarel, thanks for taking the time to share these workarounds 😄

This discussion has been closed.