ssh agent requires wifi and bluetooth to be turned on when using Apple Watch

Community Member
edited October 2022 in SSH

Version 80904044 / Mac.

I use my Apple Watch to approve access to items in my vault. One nuance of this, however, is that when bluetooth and/or wifi are turned off on my Mac, the SSH agent flashes the approval dialog on the screen for a split second, after which it disappears, and I get the error "sign_and_send_pubkey: signing failed: agent refused operation". Turning on wifi fixes the problem, but it can cause problems when I specifically turn off wifi for one reason or another (like, when I'm connected via Ethernet and don't want to associate with a wifi network).

It would seem to me that, in the case that the Apple Watch is unavailable to 1Password, it should prompt for the master password, no?

1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Browser:_ Not Provided


  • Hi @DjPadz, and thank you for your questions!

    This is actually part of Apple’s Auto Unlock – it requires Wi-Fi and Bluetooth to be active. The requirements are listed on Apple’s support page:

    It seems you don’t have to be connected to a Wi-Fi network, but it does have to be on.

    For your next question, currently SSH requires biometrics or Apple Watch. This is a known limitation, and something we are looking at improving down the road.

    Let us know if you have any other questions!

  • DjPadz
    Community Member

    Hi, Brian- Thanks for the response.

    It looks like the issue may have been temporary. Now, when I try to use the ssh agent, and wifi or bluetooth is not enabled, I (properly) get the pop-up asking for permission to use the key, and then, if necessary, get prompted for my master password.

    I'm not sure what changed, but it certainly wasn't the version of 1Password on my machine. Must've been something that worked itself out when I updated to Ventura. ¯_(ツ)_/¯

This discussion has been closed.