1Password autofill automatically disabling

loggorloggor
Community Member

I'm trying to figure out what is triggering it.

I ran into this issue yesterday and again today. I usually use the autofill on Samsung Keyboard (same as you do with Gboard), but yesterday the autofill suggestion didn't show up when I was on a login page. So I opened the app and went to the autofill settings. The autofill was completely disabled so I tried to reenable it, and a popup took me to the Android settings for "Autofill services". There was a list with Google, Samsung Pass, and 1Password, but 1Password was already checked.

I managed to resolve it yesterday by changing from 1Password to Samsung Pass, and then again from Samsung Pass to 1Password, otherwise, the autofill on the 1Password app wouldn't mark the autofill as enabled.

I was trying to use the autofill and had to redo the procedure above again. To summarize, every time this happens I have to switch the autofill to some other app and then back to 1Password, otherwise, the autofill switch in the app won't turn on, and the autofill won't work.


I'm on a Samsung S20+


1Password Version: 8.9.3
Extension Version: Not Provided
OS Version: Android 12
Browser:_ Brave

Comments

  • ag_timothyag_timothy

    Team Member

    Hi @loggor, thanks for letting us know this has been an issue for you.

    When Autofill is turned off in the background, battery optimization is often the cause. I'd like to ask you to set battery optimization for 1Password to Unrestricted:
    1. Open device settings.
    2. Tap Apps.
    3. Search for and select 1Password.
    4. Tap Battery.
    5. Tap Unrestricted.

    After changing that setting, let us know if Autofill continues to turn off. Thanks again!

  • loggorloggor
    Community Member

    @ag_timothy I made it unrestricted as you said but it didn't fix. I may have found the source, but not the fix. I think it's Samsung's game booster turning something off whenever I play a game for a while. But I haven't found a way to make it ignore 1Password. Isn't there a way for 1Password to recheck if the autofill is set and reenable itself? Because when I try to reenable as you can see in the screenshots, 1Password is already set as the default autofill app.

  • ag_timothyag_timothy

    Team Member
    edited November 18

    Hi @loggor, good find! I've done some testing with Samsung Game Booster and I can reproduce similar results. I've filed an issue with the development team here so we can investigate further.

    In addition to selecting a different Autofill service then switching back to 1Password, I found that restarting my device also correctly reset Autofill. If I come across any other workarounds, I'll be sure to let you know.

    ref: dev/core/core#18620

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file