Integration with GBoard no longer working right?

jkane001jkane001
Community Member

Greetings!

For the last several weeks, I've noticed that GBoard no longer shows valuable 1Password integration, but instead just shows "Open 1Password". I have to tap that, auth into 1Password, and then select the login I want to use. To its credit, the site or app I am using is generally presented immediately, and I just have to tap, but I really liked that I used to be able to tap a matching site/app or "Create a Password" right from the suggestion bar in GBoard before.

I do have 1Password set as my autofill provider.

Note that this problem is being discussed on Reddit as well, so it's apparently not just me.


1Password Version: 8.9.7
Extension Version: Not Provided
OS Version: Android 13
Browser:_ Chrome
Referrer: forum-search:gboard

Comments

  • ag_timothyag_timothy

    Team Member

    Hi @jkane001, thanks for letting us know this has been an issue for you.

    I haven't been able to reproduce this issue with Gboard on any of the devices I have on hand. First I'd like to ask you to confirm that Show filling suggestions is on under Settings > Autofill and that the appropriate account or collection is selected on the next setting down, Show filling suggestions from.

    Next I'd like to ask the following to help determine the issue:

    • Which version of Gboard is installed on your device?
    • Do you notice the same issue with a different keyboard (SwiftKey for example)?
    • Does the same issue occur in other browsers and apps?
    • As you mentioned a change in recent weeks, did you notice this after updating your operating system, switching between a production and beta or other notable changes?

    Thanks again!

  • jkane001jkane001
    Community Member

    FWIW, it seemed like a couple of people in Reddit (myself included) that had the problem, experienced it after re-installing 1Password.

    Also, yes "Show filling suggestions" is enabled, and the correct account/collection is selected.

    • GBoard is 12.4.03.482060964-beta-arm64-v8a99078314
    • I've never used another keyboard, but I can try that out later.
    • Same behavior applies to any app or browser. Not just websites, but apps as well that have this happen. In other words, I never see the suggestions anymore.
    • I did uninstall 1Password and reinstalled it, TBH I can't recall why, but after that is when it seemed to change behavior.
  • ag_timothyag_timothy

    Team Member

    Hi @jkane001, thanks for the additional info.

    I've done some more testing and believe I can reproduce this issue. What seems to trigger it for me is updating to the 8.9.7-7 beta, then new items or items that I edit will no longer show filling suggestions. Unedited items created before updating appear to still display Autofill suggestions. Switching back to the production version resolved this issue for me.

    It looks like our development team is working to resolve a similar regression that popped up in one of our internal releases. If it's the same issue you're running into, that fix should resolve it as well.

    If you're using the beta, I'd like to ask you to switch to the production version, version 8.9.3 to check if this issue persists. You can check which version is installed from Settings > About in 1Password for Android. You can find steps to switch to production in the guide below. Before uninstalling any version of 1Password, please confirm you can sign in on 1Password.com or another 1Password app and that you have your account credentials handy.

    Let me know how that goes and thanks again!

    ref: dev/core/core#17695

  • darrenkdarrenk
    Community Member

    I had the same issue and thought I'd share that the solution above worked for me. Thanks!

  • ag_audreyag_audrey

    Team Member

    @darrenk, thanks for confirming that Timothy's solution worked for you!

  • jkane001jkane001
    Community Member

    Sorry for the delay, but yes, reverting from beta fixes it. Note that I had gotten a new beta build a few days ago which did not seem to fix the problem, so if the regression was fixed in the most recent beta, that didn't seem to fix this issue.

    Also, I don't think the autofill settings in the beta include the setting to show the autofill above the keyboard vs below the field.

  • BrendanR1PBrendanR1P

    Team Member
    edited November 28

    Hi @jkane001,

    Would this new beta build that you mentioned you had gotten a few days ago be version 8.9.10 - 80910026? This can be checked by opening the 1Password 8 for Android app, tapping the profile icon in the top right > Settings > About

    If so, upon testing this version on my own device, autofill suggestions were successfully appearing at the top of my keyboard for a number of websites I had tested. The keyboards I had tested were Gboard and Swiftkey.

    In regard to the autofill settings, I can see a new option is available in the Autofill settings of the app (Settings > Autofill) called Display autofill prompts with the two options available being Above suggested keyboards or Below the fields they relate to. Upon testing both these options on my own device, they worked as expected.

    I hope this helps

    -- Brendan

  • jkane001jkane001
    Community Member

    Well, weirdly, that's the version I seem to have now, even though I'd uninstalled, removed myself from the beta, then installed from the Play Store again. But it does work now, so I'll take it

  • ag_timothyag_timothy

    Team Member

    Hi @jkane001, I'm glad to hear it's working now!

    I regularly install and uninstall apps to check behavior in the betas versus production and find removing myself from the beta first, then uninstalling and reinstalling typically works rather than uninstall, leave, reinstall. I'm not sure if that's intentional from the Play Store but just what I've found. Thanks again!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file