1password 8.9.8 keyboard shortcut gets changed

snowysnowy
Community Member

If I attempt to set Quick Access or any of the shortcuts to Cmd + Opt + \ the shortcut recorder modifies it to Cmd+C

Cmd+C will now invoke whatever I attempted to assign the above shortcut too and the old one will work as well.


1Password Version: Not Provided
Extension Version: Not Provided
OS Version: Not Provided
Browser:_ Not Provided

Comments

  • Alvin.L_1PAlvin.L_1P

    Team Member
    edited November 22

    Hey @snowy 👋:

    Are you using a non-US keyboard layout by chance?

    Alvin

  • snowysnowy
    Community Member

    I am not. I will attempt to get screen recording of it.

    To provide little better description. The Shortcut recording field will show the first 2 modifiers and when i press the \ the field changes immediately to showing “ ⌘ + C” and after that ⌘+Option+\ and ⌘+C will invoke which one I happen to be assigning.

  • Dave_1PDave_1P

    Team Member

    @snowy

    Thank you for the reply. I was able to reproduce the issue and, on my end, the problem was caused by an Alfred shortcut:

    image

    Are you using Alfred by any chance? If you are then can you remove the Selection Hotkey in Alfred and then try to set the shortcut in 1Password 8 again. I look forward to hearing from you. 🙂

    -Dave

  • snowysnowy
    Community Member

    so yes I am. I actually run a few automations apps (BTT, Raycast, FastScripts) in addition to Alfred. I went through all the apps and workflows plus sysprefs for shortcuts. It got me wondering if that was the issue. I changed it in Alfred (actually encountered bug in Alfred trying to leave it blank that's for another forum). However, it fixed the reassignment to Cmd+C, and wouldn't assign anything. I still couldn't assign Cmd+Opt+\
    So I used ShortcutDetective (irradiated labs). Discovered something called "AXVisualSupportAgent" was using it, which led me to disable this "Use keyboard shortcuts to zoom".

    Now it would just roll back to the old shortcut (Control+Cmd+) I had tried to use. When I tried to set the desired hotkey. (Cmd+Opt+) So 1Password still won't accept it.

    And I decided to test after all this to see if I could use the hotkey elsewhere without issue. So in Raycast and Alfred it will let me assign this shortcut and it works for the given action I am assigning it too. No oddities.

    so it seems to be how 1Password is trying to capture this specific hotkey?

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file