Password auto fill intermittently not working iOS

Community Member

With the 1Password 8 on my iPhone and iPad, in Crome or Safari browser my password is not auto filling correctly. For example, Citibank credit card site, I click on the username, click on passwords in the autofill bar, the 1Password login pops up, I select my Citibank account, 1Password fills I the username and password, but the password fails. I need to go to the 1Password App, search on my Citibank login, copy my password, go back to the browser, paste the password, then click the go or submit button and I log in just fine. In other words my username and password are stored correctly in 1Password, but it cannot fill in the password automatically.

I don’t have a full list of sites, but it just happened when I tried to login into my Citibank account.

This never happened in 1Password 7. It’s a new issue in version 8. My wife says it’s happening to her on a few sites as well.

1Password Version: 8.9.7
Extension Version: Not Provided
OS Version: 15.6.1
Browser:_ Chrome
Referrer: forum-search:Password auto fill intermittently not working iOS


  • Hey there @dlandwirth

    We do hear about some apps (or websites) doing this when autofilling, where they claim that no password has been entered when it has, or that the password is wrong when it isn't. Although you only mentioned one example, we do find that when this happens, it tends to be with banks or other financial institutions.

    These apps or websites are usually watching for some "human activity" on the keyboard, which autofilling won't provide, but copying and pasting will. Try this:

    1. Autofill your details as normal.
    2. Add a character, such as a space, to the end of the password, and then delete it.
    3. Try signing in.

    If that works, then simply adding and removing a character has satisfied the form that you're not a robot. It would also confirm that the password that is being autofilled is correct, so both 1Password and iOS's Password AutoFill system have successfully done their part.

    That kind of "human activity" check is a design decision taken by whoever built that form, and unfortunately there isn't anything technical that 1Password can change about that. In that case, I'd suggest that you let whoever runs that app or website know that it doesn't accept autofilled passwords.

    Give that a try and let me know how you get on. I'll be here if you need further help. :)

    — Grey

  • dlandwirth
    Community Member
    edited November 2022

    Grey, adding a space and backspacing worked on CitiBank. If the methodology doesn’t work on other sites, I’ll let you know. Thank you!

    It is funny though, I don’t recall this happening with 1Password 7 or earlier. Did something change in the method of pasting with V8?

    FWIW, when I went to add the space on the Citibank site, there appeared to be a gap between the end of my password dots and the cursor. Wider than one character space. However, when I pressed space on my “keyboard”, the gap closed (disappeared), the cursor shifted left to the end of the last dot, and then a normal size space appeared. When I pressed backspace, the cursor again was at the end of the dots. I pressed enter and was able to login.

This discussion has been closed.